Remote access to Zorin from Windows 10 RDP

I’ve recently installed Zorin on an old PC (impressed so far, despite steep learning curve) with the intention to use it as a general utility backup device and for Audacity MIDI support to my Yamaha keyboard. As such, I’d like to be able to control it from my Windows 10 desktop but I’m having problems setting up that interface.
I’ve just gone through steps from an Ubuntu Forum that involved:
$ sudo apt install xrdp
$ sudo systemctl enable --now xrdp
$ sudo ufw allow from any to any port 3389 proto tcp
That all went OK, but then tried to established a Windows RDP connection and received this response:
“RDP can’t connect to the remote for either: 1) Remote access to server not enabled; 2) Remote computer turned off; or 3) Remote computer not on network. Make sure of 2 and 3 and remote access is enabled.”
2 and 3 are irrelevant, but I have no idea whether or how Remote Access is enabled on my Zorin system.
I’m also confused about User names. On my Zorin desktop my user is referred to as ‘GeoffW’ but at the shell level it’s ‘geoff’ (amongst all the other listed standard user names including ‘root’).
Please excuse my low level of knowledge in this field, I’m a long (still) standing Windows victim (despite all the MS related trials and tribulations), but I’m determined to get my head around this Linux stuff. FWIW, I’ve also setup a FreeNAS Server and have been through a few nightmares in that area as well, (issues around file permissions) but that’s for another Forum another day :smile:
Thanks in advance for any guidance that might come my way.

I’ve just tried on Zorin OS Core.

sudo apt install -y xrdp
sudo adduser xrdp ssl-cert
sudo systemctl restart xrdp

I don’t have a firewall on Zorin OS at the moment. I had to switch off my Windows client VPN to be able to resolve the computer name.

From Windows I was able to run the following and connect to the login page successfully.

mstsc /v:hostname

I’ll continue to work on this as I’m having issues after connecting.

Hello all - I recently had a similar issue connecting from Windows to Zorin, and it took some looking and piecing together to find what worked. Here’s what worked for me, and what didn’t:

1) Your username can’t start with an uppercase letter - the login process won’t tell you that, it just won’t work and results in some arcane error like “cannot connect to display 0” or the like. Zorin let me create whatever username I wanted, which was my name (including i-cap, space, all those bad things that work perfectly and looked nice in Zorin when I logged on). I changed mine to all lowercase, no spaces or special characters.

2) Your password must be a strong password - using 3 of 4 of the [uppercase, lowercase, number, character]. I had a simple password because I’m on a private inaccessible network, had to change it. Similarly, the RDP attempted connection won’t give you a hint that’s the case, it just won’t work. Check out this link for confirmation/info [see 11-03-2020 post by Sevemo]: https://www.linuxquestions.org/questions/linux-newbie-8/xrdp-sending-login-information-to-login-manager-failed-display-0-a-4175676157/

Also, here’s how to avoid having the RDP session immediately show, then disappear: https://askubuntu.com/questions/678979/remote-desktop-rdp-blank-screen-and-aborts-after-disconnect

Here are the steps that worked for me (in addition to what’s above):

first:
sudo apt-get install mate-core
then:
echo mate-session> ~/.xsession

Lastly, the RDP then worked from Windows to Zorin, but wasn’t as beautiful as the Zorin UI is natively (it defaulted to Gnome or something, which could be changed using Appearance, but not as well as I wanted). In the end, I ended up making Zorin my main machine, and RDP’ed into my Windows boxes using Remmina - so much better. Easy, clean, reliable, fast, effectively pixel-perfect remotely, all that. Audio was fine, though I have a headset on one of the Win boxes that I just use (while remoting in for the desktop) and turn off remote audio, works great.

Hope that helps someone from all the digging, piecing together, and head-banging I had to do.

2 Likes

I've tried and tried all these and other Forum tips with no success. I've created/deleted/edited Windows Credentials, changed to another Zorin User Login (to avoid possible clashing with current logged in Zorin User), tried all the options in the Windows RDP Login screen (Xorg, X11rdp, Xvnc, console, vnc-any, sesman-any, neutrinordp-any), none of them work.
i've done all the sudo RDP enabling scripts, yada, yada.
All I get from Windows RDP is:
connecting to sesman ip 127.0.0.1 port 3350 [not my Zorin system iP]
sesman connect ok
sending login info to session manager, please wait . . . .
login failed for display 0

It's connecting to local host, 127.0.0.1 is the loopback address of the local machine. Have you tried configuring it with your other machines ip address? Remember to add either the cidr or subnet mask, depending on which it'll take. You may also have to open those ports in the window and Linux firewalls.

Edit:
Just thought of it, you may need to go into your windows network and sharing options and enable sharing on private and domain networks to allow it to see other computers on the network. Could this be a port forwarding issue on your router? Does it work if you're router is set with static addresses for these two machines?

Did you use this guide?