Remove virtual keyboard/OSK SOLVED


Had this issue a while back and it drove me crazy (at least on my touch screen laptop)

Tried all sorts of published fixes/hacks and zero result.

I attacked this issue again this weekend and discovered the root cause of the issue in a note in a change control log for gnome where a developer decided that gnome, where a device has a touch screen, should always present the OSK no matter what the "accessibilty" toggle is.

I also discovered that the virtual keyboard was channeled thru the "ibus" process.

So I did "apt remove ibus", rebooted and joy of joys, no stinkin' OSK.

Everything works fine and if you look at the rather skinny info on ibus in wiki (Intelligent Input Bus - Wikipedia) its hard to know specifically what end user would be affected by its removal.

The wiki talks about "terminal emulators, editors and web browsers" but the ones I use all work fine... noting that I dont work in a multi-lingual environment.

If you find you really need it you can always reinstall it.


1 Like

For the most part, IBUS deals with users that use the non-latin based languages.

However, this doesn't mean that removing it is necessarily safe. You may have other software that has ibus set as a dependency even if you do not use those languages.

Removing ibus may resolve your issue, but it will generate errors.
Alternatively, you could remove the on-screen keyboard, instead.

sudo apt remove onboard onboard onboard-data onboard-common

You researched this, learned what was working with what and smartly made a decision. Much better than trial and error or blind-guessing.

onboard isnt used by Zorin Core.

The virtual keyboard is embedded in the underlying gnome GUI code so isnt a 3rd party app.

As per the change log, the root cause is a delibrate change by a gnome dev and as such this isnt a Zorin specific issue (or any other desktop based on gnome... its intrinsic to the baseline gnome code)...hence why people using many different Linux platforms have been moaning about it.

There are no errors after removal... dmesg on reboot shows no issues at startup and running my "stuff" on my desktops then checking dmesg again is clean.

ibus really is a noddy little app (not saying its not useful) so its "reach/scope" when removed is small

"You researched this, learned what was working with what and smartly made a decision. Much better than trial and error or blind-guessing."

Thanks for the compliment ... but as a Unix/LInux systems level developer of 40+ years experience, I have some experience in hacking stuff so as not to break a system.

I have restorable VM's I can hack stuff in, I have bit level "dd" backup images of physical test systems which are easy to restore etc. Been doing this a while.

But I have no experience with desktop software like gnome... desktops have never been something I have needed to worry about professionally as all my work products have been below this layer.



It is... However, I am on Zorin OS Lite and that may be why I am still seeing Onboard if the On Screen Keyboard on Zorin OS Core is part of Gnome Desktop (removing the need for Onboard App).

This being the case, in order to give this thread a marked solution, I am marking your post above as the solution so that others can find it helpful.

EDIT: Wait... is Gnome still using Caribou?

Ok... point taken... was refering to Zorin based on Gnome so yes onboard may well exist on Zorin Lite (as you point out)

EDIT: Wait... is Gnome still using Caribou?

As noted above I am no Linux desktop expert but from what I can see, as at some point the embedded gnome OSK become the default and as I found, installing onboard/Caribou or any other 3rd party OSK app didnt supersede it.

My issue was I didnt want ANY OSK... my laptop has a keyboard.

1 Like

I understand. My aim is that there may be users that are using ibus and in need of a solution on Zorin OS Core.
If I find a solution that applies to those users, we can just annotate it in the O.P. or the marked solution above.


I will update this thread with the gnome dev's change log entry and maybe, given your expertise with gnome, you can fix up this issue.

Gnome as a organization, dont appear to want to fix what they broke even though many people have reported it to them


1 Like

In we see this comment against gnome 3.35.91:


  • Only enable OSK automatically if touch-mode is enabled [Carlos; #872]

Now I may be reading too much into this (and I couldnt find any details on what I assume is commit 872) but one could construe from the description that OSK will always be enabled if touch mode is enabled (which will be the case if you have a touch screen device)

I also have anecdotal correlation (not recorded here) that the issued related to not being able to disable the OSK via the "accessibilty" toggle occurred from gnome 3.36.

Might be a red herring.. or not but no matter there is 100% an issue with the OSK popping up on gnome based platforms when supposedly disabled and hopefully Zorin can fix this.

By the way... having used Linux for decades.. Zorin is 100% the best desktop out there. Highly and easily configurable and just gets out of the way.



Oh, I wouldn't go that far. I am more similar to you in that I lean toward backend and I sit back and let others handle frontend issues on Gnome like settings and tweaks.

From what i can tell, the setting in Accessibility is a different setting than the OSK that automatically is enabled when using a TouchScreen.
On the surface, this may appear as though Gnome is giving deference to accessibility features (Something Gnome is pretty good about, normally) but it really looks like this is more of a shortcut - it is easier to code it this way and requires less code and maintenance doing it this way than if they were to allow Complete User Control (which is also a strong trend in gnome devs behavior...)

I suspect that Caribou is the thing we need to focus on.

If we install dconf-editor

sudo apt install dconf-editor

Launch dconf-editor and navigate to /org/gnome/shell/extensions/caribou/
For the setting "auto-show-on-touchscreen", toggle the switch to OFF.

I believe this method should allow ibus users to disable the OSK without losing access to their language libraries.
@BluckMutter , it is up to you if you feel like directly testing this by reinstalling ibus and trying this method.
Otherwise, this can stand as an available potential solution for ibus users.


will play with this tomorrow and report back

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.