Remove Zorin

It turns out for my laptop I need to go back to Windows 11. I had a Lenovo Ideapad, and when I use the restore USB drive I have, it cannot detect the SSD any longer. I can boot into Zorin just fine, but even a Windows 11 recovery tool cannot see it. I can get into the Windows 11 recovery command prompt, but when I run "diskpart", then "list disk" it only shows my USB drive. HELP!

Do you have secureboot disabled in the bios? on my dell when i plyed around with win11 rtm, i had disabled secure boot (to play tricks with tpm) but it it also turns off some windows boot mode - and i couldn't select the onboard emmc for install - enabling secureboot allowed the drive to be usable

I would look at the boot and security tab to see if you have either secureboot off, or have some enhanced security enabled such as boot-virus protection or secureos or something that might be preventing windows setup from changing or accessing the boot drive

Check lenovo support page for you machine, you might need to download a driver for your drive, looks like some lenovo machines use a raid config that windows needs the raid driver downloaded to detect the drive

Here are the screenshots from my BIOS. Pretty simple options, but I do have secure boot enabled. The options in blue are the only ones that I can change. Also, I am posting this from the same laptop. Zorin sees the drive just fine and I actually just reinstalled it to make sure the drive is working.




You need the nvme drivers from levono for that drive.

https://forums.lenovo.com/t5/Lenovo-C-E-K-M-N-and-V-Series-Notebooks/NVME-UMIS-RPJTJ256MEE1OWX-win-drivers/m-p/5095319

When you install zorin, it creates a ext4 file system. This is not natively read by windows (requiring fat32, efat32 or NTFS). If there is no free space and no partitions with one of the above mentioned fs structures, windows may not see the drive. The installer may have the drivers necessary already, but miss the drive due to the aforementioned reason.

Thanks 337harvey. I formatted the drive using GPART in both FAT32 and NTFS and the installer still does not see the drive. DISKPART just won't list it. But the drive shows up just fine in Zorin. Zorin will run like it should on the drive I need to clear and install Windows on. Could there be anything else? I still get 0xc0e90002 when using the Lenovo USB recovery option. Windows 11 USB recovery will run the setup, but will not see the drive. Anything else in the BIOS screenshots you think I could change or try? I think I've done everything I can think of.

It is possible that your bios needs an update (this will include basic firmware to recognize hardware). You can attempt to upgrade the bios either from a live image or from Linux by going to the manufacturers website and following their directions for a Linux distribution (or the installer from a live windows image). That's what it sounds like to me.

That series of drives RPJTJxxxMEE10WCX requires a driver from lenevo for windows setup to see it, you would need to add the drivers to a usb and add them like a raid driver.