Removing Windows from dual boot/Zorin OS pro 16.3/Asus vivobook S533

I'm following the instructions I got in the forum here and I just rebooted after deleting partitions. I'm attempting to remove the microsoft boot loader entry and typed in os-prober and got the response
unshare failed: Operation not permitted
rm: cannot remove '/var/lib/os-prober/labels': Permission denied
I have to admit I'm loving the straightforwardness of using terminal to do what you want in the system. I'm going to have to learn Linux.

Re-run os-prober but, with elevated permissions: sudo os-prober then very importantly sudo update-grub and then reboot.

If you don't run the update-grub command afterwards, it'll stick around. The guide I posted in the other thread has how to delete stubborn Windows boot items as well.

1 Like

I agree 100%.
I was resistant of the terminal when I first moved over from Windows. But before long, its power went to my head.

1 Like

I did both; sudo os-prober and sudo update-grub and rebooted. Tried os-prober and still denied permission. I'm going back to the other message to check for stubborn windows boot items. Wish me luck!

1 Like

I've gone over the messages I could find and didn't see it. I have to admit I'm short on patience when I'm in the middle of computer crisis so I probably missed it somewhere. I'll keep searching.

I found this. Would this work to disable that os-prober, operation not permitted line/command

echo GRUB_DISABLE_OS_PROBER=false | sudo tee -a /etc/default/grub

Nevermind, I tried it and it said Permission denied.

What is the exact command you are running?

sudo os-prober


This morning I ran sudo os-prober and it asked for my password. It then gave me this command line:
/dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
I then followed, like the instructions said, with: cd /boot/efi/EFI/
It said permission denied.

I asked for a list of the boot files and it listed 36. Like this:
drwxr-xr-x 2 (my name) (my name) 4096 Oct 4 12:45 Desktop
All of the files were drwxr-xr-x, all same date and about the same time and were documents, downloads, music, pictures, etc.
Nothing like the instuction sheet showed as an example of what it should have shown. It only showed the thumbdrive I installed of files from windows.

Can you try elevating to root, first:

sudo -i

Once elevated run your commands without using sudo, since sudo is not needed due to your terminal remaining elevated to root.

I did that. I'm at

This is where I type in rm -rf Microsoft/ Correct?

I double checked the path and it said 12. It lists boot, Microsoft and Ubuntu. 2 root boot, 4 root microsoft and 2 root Ubuntu.

I went ahead and typed in rm -rf Microsoft/ and it just gave me back the same prompt command line listed above that starts out with root@(myname).

With this last edit I will complete this post.
I went ahead and took the plunge. With my newfound confidence after my crash course in all things Linux along with my instructions I had gotten from PlumpKibbles I followed through and successfully wiped windows from my computer and upon reboot it is windows FREE!!
Thanks for all of everyone's help!
I will be back I'm sure. I couldn't have done it without you!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.