Repair Zorin OS system files while keeping other data

Hi there team,

I have this peculiar problem that appeared recently.

I installed proprietary NVidia drivers for my graphics card (version 460-server) from the Software & Updates app, and it went smoothly. Restarted, and voila--Nvidia card was recognized, and Nvidia X Server was working, giving me options to change etc.

However, for the love of all that's good and worthy, I was not able to turn off vsync. It seemed that some apps that didn't want vsync turned it off for them, but some others (old games, more importantly) didn't, which resulted in sluggish and delayed performance (mouse swim phenomenon). Turning off [Sync to vblank] in X Server didn't do anything, vsync was still on, as the driver itself showed this in the upper left corner of every such app that used the NVidia card. Tried running X Server with sudo, tried inputting that config through console, but to no avail.

Alright, so I decided to install other drivers because maybe that's the problem. Went to NVidia site and used their search to find those that fit my card, which were 415-server. Tried to install them, but the installer kept saying that, first, NVidia drivers are in use (which I successfully managed by uninstalling NVidia drivers, and then the Noveau driver kicked in), and then that Noveau driver is in use, to disable it. Tried various solutions to disable it, to no avail.

But during these attempts something broke. Now I can only use Zorin with the Noveau driver, as installing an NVidia driver simply doesn't let lightdm run, and the system is stuck at (after)boot. I can, of course, run the console there, where I can uninstall NVidia drivers, after which the system boots fine. Another thing that's happened is that the boot screens changed, and now look different--not like those on Zorin OS.

So basically, I did some stupidity, and changed some config files that now do not let me use Nvidia drivers at all (none of the ones present in the Software & Updates app work). That would've been fine if Noveau's performance wasn't so dismal in games.

Sorry for the long overture, but what I am primarily asking is a way to fix system files so that I can return the system to its Zorin OS state, but at the same time not reinstall everything and lose bunch of stuff that I've set up.

The second thing is, can anyone after this help me with installing NVidia drivers so that I can finally turn vsync off and have full performance in games and other graphical apps? I know that some apps (like, some games) have console commands to turn off vsync, but not all of them, so I want to be able to do this globally, or per app. The X Server app has this per-app setup option, but it didn't work--per-app nor globally.

Thanks a lot,

Can you try sudo ubuntu-drivers autoinstall ? That may be the same result as through the Additional Drivers in the updater but it's worth a try.
I've always used my individual game settings to disable vsync - did you use some other method?

1 Like

Thanks for the suggestion. Did that, now it seems the NVidia driver 460-server got installed along with X Server. I can again use settings and use the GPU, and lightdm is not stuck.

However, I still cannot disable vsync. In X Server's OpenGL settings, [Sync to vblank] is disabled, but it is still enabled in some apps as indicated by the upper left indicator. Yes, some games allow to turn it off, but some (most notably, Windows games that I run through Lutris) don't. This particular game doesn't even have the option to disable it in-game, or through console, so it seems I am stuck--unless I find a system-wide way to disable it.

My login screens remained weird. It seems that those from Ubuntu got installed somehow, I'll have to find a way how to remove them and restore Zorin OS' ones.

Synaptic would be a convenient method to see what packages are installed. Search nvidia-driver and add/remove there.
I don't have any suggestions on the vsync side, sorry.