Resizing Partition

How do I resize my partition? I tried to resize it but the + button is grayed out..

i want to resize the /dev/sda4 partition (my system partition) with the 72GB unallocated space but sadly there are a lot of partitions (and..some 1MB unallocated space i used to conver mbr to gpt) in the way of the unallocated space. Any help will be appreciated!


Two requirements that must be met are that the drive must be unmounted in order to make modifications like resizing and reformatting. If you are modifying your daily use drive, you can boot from the LiveUSB of Zorin OS to run the Gparted partition manager.

If you are looking to resize a partition, the free space you wish to claim must be adjacent to the space you wish to resize (In other words, they must be next to each other). If they are not, then you may need to move things around in order to get free space next to the partition you wish to resize.

yeah that's the problem, there are BOOT partitions in the way as well!

I ran into this problem when working with a Windows-based drive. The only solution I was able to do was to use Macrium Reflect (free edition) to image the existing data, wipe the drive, and then reinstall everything.


Partitions can be moved around. It's not a fun task.

I also agree that a full reinstall is the easiest way to go.
It just comes with more benefits, less risk and is less hair-pulling.