Restart after shutdown

Hello, I need help. When I shut down the laptop, it restarts again for no reason, and when I shut down the device in Windows, it shuts down normally.

In your BIOS settings, under Power Tab, do you have an option for "Wake on X"?

1 Like

no I don't

You might try a different kernel. Which edition of Zorin OS are you using?

i am using Zorin OS 16.3Core

Let's test:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Reboot in order to boot into the later kernel.

Then use your computer normally and observe to see if there is a difference the next time you perform a shutdown.

Unfortunately there is no change

This bug was happen to me too, everyday for years now, since Zorin OS 16. And no solution still.
And I believe it's happen because secure boot is "on" on my laptop bios and I'm currently cannot change that option to "off". Or may be I'm wrong?

Do you get a complete shutdown after issuing sudo init 0?

Also, what make / model of machine are you using? There may be some quirks related that may point to an issue.

Safe boot is closed for me and the problem still exists

No I didn't, my laptop model is HP ZBook 15 G2

edited adding quote
Hem... so may be Zorin OS 17 will fix this? or...
But, I don't have time to doing an upgrade, at least for next 4 months.
If you have plan to upgrade to 17, please ping me if this problem was fixed.

Can you specify what 'closed' means?

I updated to zorin os 17 and the problem still exists

I mean I've turned it off before

1 Like

Assuming you use the power button or the menu buttons to initiate shutdown, what if you type shutdown in terminal? Does it reboot then?

If you use the physical power button, can you check what behavior is assigned to the power button in your settings window? I believe it's in power settings. Could be that it's set to sleep/hibernate, rather than shut down, so it would appear to reboot but really it's waking up?

Do you have something called "Fast Startup" enabled? Should be a BIOS option if so.

Note, "Fast Startup" is a Windows setting, wheras "Secure Boot" is a BIOS setting.

1 Like

This is true; there is a confusion wrinkle, however. There is a Fast Boot option included in many BIOS settings these days, as well.

2 Likes

I found the Fast Startup option in the BIOS, closed it, and tried again, but it didn't work


@Aravisian I wanted to add that these messages appear to me when I boot the system