Revert back to X nouveau driver instead of NVidia manual installation

Hi !

I'm new to Zorin (Pro version), and I'm getting back on Linux. I did use Slackware, Debian and Red Hat Linux (not named Fedora in the '90 and start of 2000).

I'm working on an iMac 2013, restored with a new NVMe SSD.

I wanted to try the proprietary NVidia driver for my card (GTX 775M), but I'm having issue with the driver. Nothing terrible, but really annoying.
I would like to revert back to the drivers, since it was better than what I see with NVidia.
The problem is that I installed manually the NVidia driver, following instruction in a forum. Now I'm unable to return to X driver.
See the screenshot below:

I did try to uninstall the NVidia Driver, and run into serious problems. There was a problem with the package removal with apt, and at reboot I was unable to log in. My guess is that it did'nt found the driver, and was also unable to revert back to X.

I went into a "try Zorin from USB" session to correct the problem and go back to NVidia. Painfull, but it worked after some hours of research.

So now my question is, how can I go back to the X driver without pain ?
Or, if someone had experience with the same graphic card as me, which NVidia driver to choose, and settings to get rid of problems like zone of the screen all messed up, police unreadable after sleep mode, etc...

Thanks in advance, and bravo for this nice distribution ! It was my choice because of the possibility to make it look like the macOS interface in a minute.

Please try:

sudo apt install xserver-xorg-video-nouveau && sudo apt ubuntu-drivers install

Reboot ... then look again to Additional Drivers and be sure you are using the Nouveau driver.

sudo apt remove --purge '^nvidia-.*'

OK, when running the first command, it says that I already have the latest nouveau driver:
xserver-xorg-video-nouveau est déjà la version la plus récente (1:1.0.16-1)

It also trigger this error : E: L'opération ubuntu-drivers n'est pas valable

I did try to reboot nowadays, but no change in the additional driver window.

I'm still on the same NVidia driver.

Is it the 390 driver?
What method did you use to install it (manually)?

If I remember right, I did:
sudo apt install nvidia-driver-470

I choose this one (470), because I've read that it is the appropriate one for my graphic card (GTX 775M).
I had to add a repo, this driver was not listed in Additional Drivers. That's also why I went to manually install.

This surprises me... what repo did you add?

Sorry, I got back into my history in command line, and I did not add a repo.

Also, the command used to install nvidia 470 driver :

sudo apt install nvidia-driver-470 libnvidia-gl-470 libnvidia-compute-470 libnvidia-decode-470 libnvidia-encode-470 libnvidia-ifr1-470 libnvidia-fbc1-470

I also managed to get rid of the problem with the sleep mode (when going into sleep mode, impossible to get back... without hard reboot).
It worked, but if the computer stays for a long time in sleep mode, when I reopen with my password, all the characters are unreadable. Like winding or something...

It seems to be hard to go back to drivers. I didn't find any solutions searching the web.

Definitely a graphics issue...

It really should be as easy as selecting on a screen. Do you have integrated Intel or AMD graphics?

The processor is Intel, but I dont think there's graphic on board.
It is Intel for Apple, and I'd be surprised they included graphics on board.
When I buyed it, I had the option of 2 NVidia's graphic card.

Is this a MacBook?

No, iMac late 2013.

1 Like

I know that the listed Best Driver is 390 - which is now dropped from all support. This then defers to the 470 driver...
But the card may be passing it's lifetime at this point.

It might be worth a shot:

OK thanks for the help ! I will give it a try.

Is the x org driver blacklisted? This may have been automatically done since the driver was installed by a custom repo. I'm surprised it didn't come up in an apt search nvidia-*-470.

1 Like

Update on my problem :

I removed everything from NVidia, using apt remove and purge.
I rebooted, but knew I would run into problem. Black screen with a cursor on the upper left, impossible to go to a tty (when trying to do so, I could see the login for about 1 second before it returns to the blinking cursor). Probably an input problem ?
Anyway, I did use my Zorin installation USB key to go in a "Try" session.
From there, I chrooted on /mnt and installed the NVidia 390 driver, as @Aravisian suggested.
Reboot back into my system.
All is OK ! And as of now, no glitch in the screen from a bad driver installation.

Thanks a lot !
(pardon my english, I'm french canadian !)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.