Right click does not work on laptop trackpad

When I use the trackpad of my laptop the right click does not work, I tried to solve it from the settings but I could not.

Could you please run this in terminal and see if it helps:

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

3 Likes

I think you have to run Gnome tweaks as the standard right click is a two finger press on the track pad.

Here’s a picture. Run tweaks, Keyboard and Mouse and select Mouse Click emulation, Area.

3 Likes

Thanks for the help I think the command solved everything :grin:

Glad it worked. To note: JGordon’s gnome-tweaks tip performs the same function, should the user prefer a GUI method.

I don’t see that GUI that showed me ‘Mouse Click Emulation’ I just get the same options I sent in the image above. Anyway I am solved Thanks for the help guys :hugs:

The app is called tweaks. It’s already installed in Zorin Ultimate.

1 Like

Gnome tweaks is available in Software for Core users.

There is a useful Mouse/Trackpad test screen accessible from the settings page. I have edited OP’s screenshot to highlight that button. (I recently found that useful whilst diagnosing a sick mouse).

mouse

2 Likes