Right Click '' Open in Terminal '' is missing when selecting Files or Folders

Hi Guys, I've been really enjoying Zorin OS 16 so far.

One issue I have, I'm not sure if it didn't come with the OS. When I right click on a file or a folder ,'' Open in Terminal '' is missing from the contextual menu. I need this to install some AMD GPU drivers and others, it's very useful for a noob like me.

How do I add that to the right click menu. I can see Open in Terminal only in desktop right click menu.

How do I get a menu like this ' from one of the Forum Moderators'

Thanks a lot

I think that this guide should help :wink:

EDIT: Interestingly, I just opened my copy of Nautilus on my Zorin OS 16 and it does contain "Open in terminal" from any directory I click the context menu open in.
But this may be due to me having installed Nemo and Cinnamon D.E. on Zorin OS.
It would have added that functionality for Nemo File Manager.

1 Like

Thanks a lot. It's actually my fault [ I'm so dumb lol ], I was right clicking inside of the Tar.xz archive, that's why it didn't appear until I extracted the content of the archive. Sorry I'm new to Linux and Zorin interface and I didn't even realize I was inside the archive extractor lol.

One thing I noticed that is unrelated, when I tried to take a screenshot either by using 'Print Screen' or Screenshot tool, I couldn't take a screenshot while the right click menu was shown. It's odd, I don't know why it can't.

Thanks again

2 Likes

I have noticed this, too... I use a different tool in order to be able to take any screenshot I need : xfce4-screenshooter
It captures the mouse pointer too, if you check the box for it to do so.

sudo apt install xfce4-screenshooter

1 Like

Thanks a lot , I will try it now :innocent:

Ok I just tried it, here is the funny thing it's same as the app included in Zorin and both feature capture the mouse.

sorry for big screenshot , there is no crop option in image viewer :no_mouth:

But what's really interesting is that both don't really change the function of ' Print Screen' keyboard button. I still can't use it to take screenshots while the right-click menu is shown. The only way to take a screenshot in that case would be by using the mouse and clicking on ' take screenshot' but as soon as you do that, the right click menu disappears. It's like a cat and mouse game :sweat_smile:

Not sure if the community already figured this out. I hope so.

Thanks

OK , I figured it out after a google search. Now it makes complete sense.

It seems the only way to that is by using the delay option by few seconds

Then just wait for it to take a screenshot even if you have right click menu shown.

I only wish it would come with a visual counter [ 3, 2, 1, snap ] but maybe I'm asking too much :smiley:

So no need for the xfce4-screenshooter app because as far as I can see it's the exact copy of the one provided with Zorin OS 16 with some layout changes. [ Zorin default app on Left]

Thanks again for the prompt reply. I'm already in love with this community :smiling_face_with_three_hearts:

1 Like

It didn't occur to me- I always set a delay :stuck_out_tongue:

1 Like

Hi, glad to hear that you solved the issue.

Would you mind to tell me where you got that awesome wallpaper?

1 Like

That's pre loaded with Zorin OS 16 Pro :smiley: :smiley:

1 Like

Thanks. Yes, I do have a Pro.
Never thought of checking the stock wallpaper :sweat_smile:

1 Like