Right Click > Open in Terminal not working


Whenever I right click anywhere and click on "Open in Terminal", I get the same error:

bash: cd: too many arguments
bash: /home/jung/Desktop/csci599:: No such file or directory

And then I go to my Home directory. How can I fix this?

You might try renaming the folder and ensuring it has no white spaces or special characters.
Or post a screenshot of the exact output.

This happens regardless of the directory I try to do "Open In Terminal". On my desktop, any folder, my home directory, etc. And its always the exact same error.

Not sure if it helps but I used to have a folder named that but did I somehow overwrite the default behaviour of "Open In Terminal"?

Gday @xeroriser Welcome to the community!

Is this a new install?
If so please let us know the app used to create your bootable device(usb/dvd)
The machine model & specs:
is this dual boot?
any additional info would be great.
eg: any recent changes etc.

Hi, this is a fairly new install, I just switched from windows to Zorin about a month ago.
When I installed Zorin I used balenaEtcher on a usb to create the bootable flash drive.

Machine specs are as listed:
Core i5-13600k
2x16GB Ram
GTX 3080 FE

Not using dual boot, straight up erased everything and did a clean install on one partition. I don't think I did any recent changes, the only thing I can think of was I was messing around with adding directories to my PATH variable today. But I can't remember if this error started happening before today lol

1 Like

On your Photo i see a double colon (": :" ) spaced.
/home/jung/Desktop/csci599: :<<<
which i would say is the issue in the path, but im a little confused as to why?
Is this a path you may have changed?

Have you checked/Changed permissions in the file manager?
you can check any terminal commands you have used in

cat ~/.bash_history

It may even be quicker to backup & install again?
Hope this helps

1 Like

hm, there is two colons in there

Does the folder include a colon / : ?

1 Like

Does this error appear when you launch the Terminal from the main application menu, like any other program? Also, have you edited your ~/.bashrc file or executed any shell scripts that you didn't write?

Yes I did make a folder earlier called 'csci599:hw1' so the folder did have a colon in there. I did what Ocka suggested and ran this:

I think it must be the first command? I added a space there on accident and added /home/jung/Desktop/csci599: to PATH? But why would that affect how I open terminal?

And if you try to cd /home etc to the directory, where does it break?

I deleted the folder and since it was on my desktop I guess it breaks at Desktop? I've never touched my .bashrc file but I just looked at it and this showed up at the end:

This seems to be the root of the issue I think? Not sure how bashrc works.

EDIT: Okay I looked up what bashrc does and deleted all of those new lines at the end and ran source ~/.bashrc and now everything works fine. Still no idea how I managed to edit the bashrc file but thank you everybody for the help!


Ok that’s weird but glad to know everything ran fine now :slight_smile:

Good evening

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.