ROG Strix 17 bluetooth and audio problems

So before I explain the problems lets me just say Zorin OS is absolutely amazing and I will never use any other Linux distribution or operating system. :slight_smile:

The link to my PC I have so you can see my exact hardware:

I have no Bluetooth at all and I did everything I could think of, Zorin / Ubuntu does not even see my Bluetooth adapter in the terminal. I have 3rd party software enabled and if it was not for that my wifi6 card would not work either. Does anyone have any idea how to get this working because I love Zorin so I am not switching distributions.

Now for the audio problem, kinda, so when I plug my headphones into my PC the speakers work fine but the microphone is not seen in the headset at all no matter what headset I use. I have to install a tool to make it work (sudo apt install alsa-tools-gui). That and just absolutely randomly my speakers in my headphones or my PC speakers when no headphones are connected will make an awful static sound that will echo the sound like a phone call to a phone call when both people are in the room sort of thing. I is hard to explain but any ideas how to fix this if you know what I mean? Like my point is if fixing my microphone problem caused this static audio problem

That and this is a small problem but my GPU RTX3060 works just fine with proprietary tested divers but neofetch shows (NVIDIA 01:00.0 NVIDIA Corporation). does anyone that has a NVIDIA GPU have a similar weird thing and a possible fix? its a small detail that is not a problem but it is just weird.

EDIT: I have disabled secure-boot and reinstalled Zorin and I still have this problem but I never used Bluetooth in a PC anyway. My GPU Works fine though even before I did this but now I accidentally set in my BIOS a password that you need to enter before the PC boots or go to the BIOS again and I can not remove it now just change it lol. accidentally more secure.

I can only assume that this is just the WiFi/Bluetooth card manufacturer providing horrible Linux drivers - as usual
or this might also be caused by SecureBoot, causing the drivers to not load (not properly load, at least)

mind sending output of lspci?

You can either just change the audio input through the settings, pavucontrol or use a GNOME extension to do that more quickly from the menu

That sounds quite weird...I'm not sure how to debug this one, let's wait what other people say

yeah you should probably disable SecureBoot, especially because it isn't really "secure", it just restricts you to only use operating systems which have SecureBoot keys lol
↑ (so, pretty much just Windows and a select few Linux distros, Zorin not being one of them)

1 Like

It is weird. I have no problems and everything works fine:

extra weird considering my card gets detected just fine here
tho ig glxinfo | grep -i "opengl renderer" does the trick

...are you using cinnamon on Zorin?
hm, haven't seen that one before

Caught me theming at the moment, so I am logged in on Cinnamon creating the Metacity and Cinnamon portion of the theme. But yes, I do use Cinnamon on Zorin. Lately, i seem to just XFCE at login...
I also have Enlightenement DE and Mate DE installed on Zorin. Others install KDE Plasma... Which I have vowed to never do again and promise to break that vow someday...

1 Like

ah okay makes sense

The device should be supported. Have you tried with iommu off?

Yup ..... I use it too .... love it as I have Gnome and XFCE installed .... tried KDE also but it didn't work to well for me ..... didn't seem to play nice with the other 3 DE .... shame but that's what it is ....

Try kernel 5.15

I do not know what you mean by "iommu off" but the linux kernel 5.16.12 fixes my Bluetooth problems but now zorin will not update and I have a red mark in my taskbar basically telling me updating my kernel was a bad idea.

EDIT: I went back the the normal 5.13 kernel so I solved the updating problem so I am back to normal.

I will install the 5.15.0 kernel and I will edit this post to say if it worked and if it caused any updating problems like I had with kernel 5.16.12

That kernel fixes my Bluetooth problem as well but keeps the updating problem as well because I is not a LTS kernel. Is there a way I can just take the Bluetooth driver and copy it to the normal 5.13 LTS kernel?

You can set iommu off as a Grub Parameter by editing grub.

sudo nano /etc/default/grub

Arrow key down and over to "quiet splash"
Here, you can add other parameters for the system to adhere to on boot.
In this case, dealing with IOMMU, you have a few options. For example, iommu=pt for IOMMU Pass Through.
IOMMU is Input Output Memory Management... Unit... I think.
Pass Through sets it so that it does not require translation to be passed through the memory.
iommu=off means that it is off, which can be useful if experiencing errors with it.
So, it would look like:
"quiet splash iommu=pt"
"quiet splash iommu=off"

Once done, ctrl+x to exit, then the y key to say yes to save, then the enter key to save and close.

sudo update-grub

to add the parameter you just changed.

Pull the 5.15.26 kernel from their repo

I know I'm very late but I am back and staying on this operating system permanently so I will be more active, I want to say I don't want to do anything to change my kernal because that would completely mess up me updating my system and repositories. Nothing would work for updating / upgrade wise.

Don't worry. Changing your kernel will not in any way negatively impact your ability to run updates and upgrades.

1 Like

Changing the kernel won’t impact your updates. Recommend Xanmod kernel.

I suggest turning off your Autocorrect, I've seen many people get "Kernel" corrected to "Kernal" that way xD

ya I should xD
spelling is the hardest thing for me so that is why I edit a lot.