Rstudio doesn't launch

Good day folks. I've been using Linux for about 9 months now (so not an advance user). I've distro hopped a bit and I have to say I'm thinking about making ZorinOS my daily driver. So far almost everything works, but an issue I'm having is with running Rstudio.

I installed base R using the instructions for Ubuntu from the CRAN website to ensure that I got the latest stable version 4.2.+ and it works. I downloaded the .deb Rstudio file from the Rstudio site (now posit.co) for Ubuntu 22 and installed it using the default software installer. It successfully installed and I can see it in the Zorin Menu but when I click on it, nothing happens (it doesn't even register in the system processes when I check the system monitor app). So far I've searched the forums but can't find anything related to my particular issue. I've tried the solutions on the Rstudio website site but none of those work. So I'm wondering if I could get any help for you awesome folks.

I tested this out in Ubuntu 22.04 (using Boxes) and both base R and Rstudio works. So I was curious to know what might the issue as from my understanding ZorinOS is based on Ubuntu.

Can you please try launching Rstudio from terminal instead of App Menu - this way we can see if any and what error messages the attempt to launch displays.

Thanks for the tip brother!
So I ran rstudio through terminal and got the message

rstudio: error while loading shared libraries: libcrypto.so.3: cannot open shared object file: no such file or directory

I looked up the error and turns out that this happens when the wrong .deb file is downloaded. I had downloaded the deb file for Ubuntu 22 thinking that Zorin was based on Ubuntu 22.04. I got the deb file for Ubuntu 18+ and it works!

It seems this user had the same trouble:

I had the same error, and Rstudio couldn't start. I'm running the Ubuntu 20.04 LTS, and the problem was downloading the wrong Rstudio distribution (Ubuntu 22). I downloaded the Rstudio for Ubuntu 18+ version, and the problem disappeared. I hope it was helpful.

I actually initially reacted to your Original Post on that same thing. You used the 22.04 instead of 20.04 package.
But... I like to check things before I speak sometimes, so I went to Rstudio download page and it said that the package was for 22.04 and 20.04.
I found it odd, since they have different glib packaging but... I could be wrong. Rstudio says...

Looks like Rstudio wrong.

Can you completely remove Rstudio, then try using the package for Bionic Ubuntu 18+?

Yes. I found that same response once I looked up the error message. Found a few others who had the same issue.

I did remove Rstudio and reinstalled it using the Ubunutu 18+ package and that solved the problem. It even launches from the app menu as well.

Thanks a lot for your help. Really appreciate it!

1 Like