Rtl8812au - can't seem to activate/test this USB WiFi adapter?

Just tried installing Zorin OS 16.2 on an old laptop and am having a problem with installing the drivers for a USB WiFi device.

The laptop is a Lenovo G780 and the built in WiFi card uses the BCM4313 chipset. However when this laptop is booted into Windows (8.1) I use a USB WiFi adapter instead because the built in BCM4313 is hopeless at any kind of range. The much better USB WiFi adapter uses the rtl8812au chipset.

I've installed drivers for the latter in Zorin OS and to test it tried to disable the built in BCM4313 chipset via the Software Updater settings under Additional Drivers but the built in device is still working as I can still access the Internet even with the USB WiFi device unplugged.

How do I ensure that the USB rtl8812au WiFi device is working instead?

You can use modprobe to remove the BCM4313 module

sudo modprobe -r brcmsmac

and you can blacklist the BCM4313 as well.

echo 'blacklist brcmsmac' | sudo tee -a /etc/modprobe.d/blacklist.conf
1 Like

Thanks, very useful. How do I add the module back if I've removed it with modprobe?

Presumably once added to the blacklist I can just edit it to remove it?

sudo modprobe brcmsmac


sudo sed -i '/^blacklist brcmsmac$/d' /etc/modprobe.d/blacklist.conf

Or with Root Elevated Text Editor.

1 Like

Thanks again. Just tried the two suggestions to remove/disable it yet it's still working for some strange reason, I can even see it under the Additional Drivers tab in Software & Updates.

If it is blacklisted and the module removed, it is pretty much impossible for it to still be working.
Did you reboot after blacklisting?

It may be the module name I am using in the commands I offered: brcmsmac

As I understood it, that is the driver name - but I could be wrong. As you know your own hardware far better than I, could you please check your hardware and see if we need to reference a different driver name?
This is an example of troubleshooting over the net based on available info and a lot of guesswork. :wink:

1 Like

Thanks, yes the module name could be the cause. Where do I find the installed module name?

Let's start with

sudo lshw -C network

and see if that shows us anything useful

What Driver is showing in Additional Software tab? I only ever saw Graphics Drivers listed there.

The lshw command states that the logical name for the network card is:


as for the Drivers in Software & Updates it says:

Using Broadcomm 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)

There we go.
You can blacklist bcma or:

sudo apt remove broadcom-sta-common broadcom-sta-source bcmwl-kernel-source

1 Like

Cheers, most helpful. :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.