RTX 4070 Ti Super is currently not supported?!?

I just installed zorin-os 17 Pro on my new PC.
Unfortunately I can't install a "good" driver for my nvidia Geforce RTX 4070 Ti Super. Is that, because its a new GPU?
Bildschirmfoto vom 2024-02-09 23-11-10

It works for the desktop and normal apps, but not for games or anything special.
Bildschirmfoto vom 2024-02-09 23-17-43
I would be thankful for help!

Can you please launch a terminal and run

sudo apt install nvidia-driver-545

I use the xswat updates for mesa and other packages:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Hi. Thanks for your help, but my card seems to need the driver 550 (545 seems to cause some issues)
Is there some way to get it?

This one shows error, when I try to install it.

Yes, you can use

sudo apt install nvidia-driver-550

Hi. The package seems to be unavailable.
Bildschirmfoto vom 2024-02-10 19-24-48
Is there a way to find out, when it will be available?

You may just need the source repository:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt update && sudo apt install nvidia-driver-550

Ok, thanks. Now I got the new driver. But I still have some issues

(It says: "NVIDIA Corporation: Unknown")
Ingame I still got the same FPS as before. Even YouTube videos won't play properly.
Do I need to uninstall the old driver?
Or are there any other settings I need to change?

It is identified everywhere else, so that is most likely just an issue with Jockey (Jockey is the Additional Drivers Application).

You may need Mesa and other updates. Please add the xswat repository and then run your upgrades:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Are you connected using HDMI, DP or something else? Or is this a notebook computer?

Hi again. :smiley:
At the moment I use a HDMI cable, but I will add another monitor using a DP cable.
I found an error, maybe it could help:

builder04@Desktop-ZorinOS:~/Downloads$ sudo nvidia-settings

(nvidia-settings:33744): GLib-GObject-CRITICAL **: 12:12:00.797: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 12:12:01.192: PRIME: No offloading required. Abort
** Message: 12:12:01.192: PRIME: is it supported? no

Its a normal desktop PC. The problems are still the same.
Secureboot is disabled!

Do I need to uninstall the other virtualbox-driver?

builder04@Desktop-ZorinOS:~/Downloads$ dkms status
nvidia/550.40.07, 6.5.0-17-generic, x86_64: installed
virtualbox/6.1.48, 6.5.0-17-generic, x86_64: installed
builder04@Desktop-ZorinOS:~/Downloads$ lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device a780 (rev 04) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation Device 2705 (rev a1) (prog-if 00 [VGA controller])

This is an important distinction.

Virtualbox, even with hypervisor, does not support GPU pass through to the guest in V.B. You cannot access the physical GPU from within Virtualbox.

I know that. I'm not running VirtualBox. This is real hardware. But this driver shows up, if I run that command. That's why I was asking why I should need it. Sorry for the misunderstanding. :sweat_smile:

1 Like

Ah, I see. I do not believe that should relate, no.

I am running the 545 driver using kernel 6.6.5 on Zorin OS 16.3 with a 3060 Nvidia card.
Everything I look up shows the 4070 running fine upwards of 525 on upwards of Ubuntu 20.04.

Is your HDMI cable(s) connected to the Graphics Card port or the Motherboard port at the back of the PC?

Its connected to the graphics card.
The thing is, that its not a 4070. Its a 4070 ti super, which was released in January (brand new). So I think there could be an issue, because its an early product. Also I found out, that MSI-branded GPUs had a driver issue. But mine is a gigabyte...

This is entirely possible. You may need to stick to the absolute latest drivers Nvidia releases and the latest kernel. The 550 is the latest Beta version. I am on the 545 and it works much better than the 525 or 535, on my machine.

You can install the 6.6.5 kernel from this repository:

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update

Hello again.
I found the issue. On my mainboard I had one PCIe 5.0-Port. I had a riser-cable installed to rotate the GPU by 90 degrees.
If I install it without the cable or in a PCIe 4.0 slot, it will work.

Thank you very mutch for your help, Aravisian!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.