Running 64bit Windows programs

How can i run 64bit Windows programs on ZorinOS 16 Core. 32bit programs are running But i cant get Sketchup Make 64bit running.

You can try running it in your browser:

If you need it installed, ensure you've got SketchUp’s requirements (vcrun2015, corefonts, .NET Framework 4.5.2) installed under Wine beforehand.

You might try installing it from PlayOnLinux... I've never tried it, but others say it goes more smoothly.

@flori1994 Welcome! :smile:

It should be able to install both - did you sudo dpkg --add-architecture i386 when installing Wine? I've kind of stopped doing that.. if it complains about it, then I'll run it for 32bit apps but normally, I just install the Win app support in Software Center and, good-to-go.. I've been doing that since eh, Ubuntu 8? :person_shrugging: long time.. *Not an instruction lol

Have you also installed Gecko and Mono for your Wine version? That could be an issue.. I've also got .Net4.8 installed on top of both Mono and Gecko; may be a little redundant but I don't have many issues - unless it's something super proprietary. The .Net4.8 install covers 4.0 and up, by the way - make sure to get it from the WineHQ downloads page here. Mono, Gecko - easier instead of searching :wink: Just make sure you get the corresponding version for your Wine version!

And of course it's paid stuff so I can't try it out myself lol But - give the .Net, Mono, and Gecko a try - most definitely get vsredist if you need it; install all of them through winecfg OR wine uninstaller the uninstaller app has an Install button to add .exe's.

One note on any .msi's - you'll likely have to install through the wine msiexec /i app.msi command.

Might want to install zorin-os-restricted-addons and zorin-os-restricted-extras for corefonts and all the other goodies - I always install the restricted addons / extras :grin:

Compared to Sketchup Make, the browser version is a complete dead end. PlayOnLinux has only Support for Sketchup 8 which is ancient (from 2010) and 2018 which requires a paid Licence. Tried installing 2018 through POL and the installation even didnt started.

Hmm, i installed the Windows App Support from the software center. However the mainproblem is that the sketchup-installer just vanishes after all files all are extracted. Normally the next installation window (as you can see here should open but nothing happens.
Installed are .NET 4.8 and Vicual C++ 2015 Redistributable.

Got it installed with the .msi installer - telling me since I have two graphics cards it can't start for some reason :person_shrugging: Gonna try something..

Didn't think it would work - changed prime-select to Nvidia with no change.

I would jump on the WineHQ forums and see if anyone has gotten it working with Wine, and what version worked.

I don't have the time at the moment to try it out and see what works on my side. I see with Wine 6 via WineHQ the sketchup version is 2017, which I can't find a download to - might be why it's crashing on me, I got a few of the newest and some of the older ones; only the .msi installer went through. But, won't start - keeps giving me errors on graphics, then changed that and gave errors on other stuff, didn't read what though..

One more thing to try..

Alright - tried both Nvidia and Intel settings, got a little further - errors on ntlm_auth, deals with 'winbind' make sure you have that installed. I got as far as fonts loading, watching in terminal running wine commands, and then failed - again. I have mscorefonts installed, not sure why it gave that error.

Some software is picky - a few apps I use won't even work with Wine or POL, bottles, or any of it; only Windows.. - That's a guide on an older version of SketchUp - newer ones may not be fully working yet. Definitely check the WineHQ site for working versions and Wine versions. I've only been truly successful with games lol..

So, Sketchup on A Linux OS - #6 by dnacadengineering - SketchUp - SketchUp Community - has some good info as well, apparently the 2018 version worked for one person very well on a newer Mint variant; still Ubuntu. Are you able to link a download to the 2017 version so I can try it out? It doesn't appear to be on their site for download.. But there are success stories :thinking: I'm gonna get back on in a bit, see if I can find the 2017 version and give it another go. And did see some success from others using Play On Linux to get it going too.


Okay I got a little further - even opening the app and selecting a template - have absolutely no idea how to use the software btw but:

I'm currently on Mint so, I'll have to grab the installer and take it to my Zorin machine to test. Am using the same available version of Wine in Mint - 6.0.3, with .NET4.8 and vcredist2015 - that's it. Already had winbind installed from other shtuff. And of course, Mono and Gecko..

That is SketchUp 2018 - random find when searching. It's just the trial so, I'm sure with an account, it will unlock when signed in. Did also get a pop-up saying 'new version available' and an option to download. The newer versions don't install, get some kind of 'wizard_not_found' with both; even the offline installer..

I didn't use POL or bottles, just Wine.

If you have an account, I'm assuming so - it seemed while searching for older versions, you can get to them easier having access. Didn't see or find 2017 to try so not sure about that one.

Yes, it worked with the msi installer (atleast for 2016 version, as i didnt found any msi files for make 2017. I would love to use the more recent versions, but the company behind that software decided in 2017 to end the free offline version and 319€ is in my eyes slightly to much.

But many thanks your idea with the msi installer was just right.

1 Like

Awesome! :+1:

Yeah, can't blame you - especially the price, yeesh.. I just happened to find the 2018 installer online and tried it out. I saw something on their downloads page about a silent installer, didn't look into it though.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.