Running applications do not appear in the taskbar

Applications running in background do not appear in the taskbar, how could I fix this problem?

Hello. Did you check if you have enabled the feature.
Right click on the taskbar then click on taskbar settings. Go to behavior and check if you have enabled show running applications.

yes, this feature has been enabled. They just suddenly disappear and I have no idea what has happened.

Hmm... maybe @Aravisian could look into this and find a way to solve this.

I see you have Z16 from your other thread, but which flavour of Z16 do you have e.g. Core or Pro?

Which Zorin Appearance format did you chose e.g. icons or description in taskbar?

it is 16-core. . Running applications in background just don't appear on the taskbar no matter what the appearance format is.

Can you right click on the taskbar and then reset settings to Default.

I don't have my Z16 running, so am guessing that option is available same as Ubuntu 20.04, where I
that was proposed as solution to similar taskbar missing icons problem.

Also, did you have icons left, centre, or right justified? Try left justified.

@zabadabadoo
I saw someone is asking a similar question in another new thread:

Do you think I should merge that question here?
Or do you think it is a separate issue?

1 Like

Hello everyone!

I've been using ZorinOS 16 for a while now and very happy with it! But I have 1 problem...

Icons dissapear

A few apps icons disappear in the taskbar over time. Like, for example, CopyQ is often gone and therefore no longer useful for me. In the task manager, the app is still there, so starting from the menu doesn't help. I have to close the app in the task manager first and then restart it to have the icon back... And then be gone again later.

Chrome icon disappears when I lock my system and log back in again.

Is this a bug, or am I missing something?

Thanx 4 the help!

1 Like

@MichCapich
Hello and welcome to the forum :slight_smile:
Your post has been merged to this thread with a similar question with a moderator's magic wand :star2:

1 Like

I had an issue recently where my Eset AV App would not load into the system tray after booting Zorin 16 Pro. I followed some advice from an Ubuntu forum which suggested I install (sudo apt install libappindicator-dev). I did that, rebooted and the Eset AV icon is in the system tray. I have installed libappindicator-dev following a few Zorin 16 reinstalls and it has worked each time. Not sure if it will work in all situations though or just for my particular app.

1 Like

I have found a temporary solution to my problem. I just need to lock the screen, the icons appear when I unlock it.

1 Like

Thank you for your welcome!
I thought TurtleFlying meant his favorites, these icons don't disappear on my taskbar. But maybe he did mean the ¨near-clock-icons¨ after all. So I get it that you inserted me here.

I have found a temporary solution to my problem. I just need to lock the screen, the icons appear when I unlock it.

For me the opposite, when it comes to the Chrome icon... :unamused:

Did not work for me... :unamused:
Thanks anyway!

Temp restart:
keyboard shortcut alt+F2
Enter the letter r

This will restart gnome-shell, restoring the taskbar. This is not a solution, but can get you out of a moments bind.

2 Likes

Thanx, but not working under Wayland.
And, no... The disappearing icons happen also in X11 mode... :man_shrugging:

1 Like