Ryzen 3400g Firefox Google graphics problem

I found this fix for a similar issue, hopefully it will help you out:

Aravisian helped me with the implementation part, here is his instruction on it below:

"You can edit the default parameters in grub by opening a terminal and running

**sudo nano /etc/default/grub**

Use the arrow key to move the cursor to the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and add your parameter separated with a space so the new line is
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=pt"
Hit ctrl+x to exit, hit the y key to say yes to save, then hit the enter key to save as current file.
The terminal should revert to normal.
Now, update grub

**sudo update-grub**