safe graphics

My first weird question (you knew it was coming). On the old desktop I use for Linux, circa 2009, I can only run very light systems due to graphics issues. Bodhi, Bunsen Labs will work on Nouveau drivers. Ubuntu 16 works on Nvidia driver 304, but you can't install it after Ubuntu 16 as that driver is obsolete and unsupported by both Nvidia and the Linux kernel beyond 4.4. So I have Bodhi 6 going, as well as Ubuntu 16 (with extended security maintenance).

I did try getting an old video card from around that era, but it wouldn't work and I resigned myself to using only light systems. (Zorin Lite is too heavy, at least 15 was). Now, I wanted to put Zorin 16 on my wife's notebook, which I did, that's working great. but to preview it, I ran Z-16 with Safe Graphics on my old machine. I actually found it quite usable, as I have a big monitor, so the weird resolution is OK on it. In fact, my aging eyes are liking it a lot. Solitaire looks pretty funky though; the cards are kind of squashed.

anyway, I installed it from the USB, which I had booted with Sage Graphics. when I ran Zorin for the first time, it booted into regular mode, which is unusable due to screen craziness. So I booted next time into Safe mode. This manages to get me into the system with Safe Graphics. But I have to do it every time, and have to restart the computer again. So it takes two starts to get going.

Now, I'm doing this primarily to re-familiarize myself with Zorin, so I can solve whatever problems my wife runs into. But it's cool to be able to run Zorin on this old machine too. I was thinking of installing Grub Customizer, so I can set Recovery Mode as the default boot. Anybody have any thoughts on this? Is there another way to do boot into Recovery mode?

Press and hold the shift key during booting ?

did not work for me

Try the escape key during boot, if that did not work you might need to change the grub timeout settings.

EDIT : I found a way for permanent Safe Graphics that is as well revertable.

Boot normal as you would always do. Open the terminal by pressing CTRL+ALT+ t (T)
Type in the terminal

sudo nano /etc/default/grub

Go with the ARROW-keys of the keyboard to the line that says "quiet splash" .
Edit that line : "quiet splash nomodeset" (so you need to add the word nomodeset)
press after the edit Ctrl+ o (oh ) followed by Enter to save the file
press Ctrl+x to close the editor.
now type in the terminal

sudo update-grub

When the terminal is done type: reboot

You are in safe graphics as a permanent setting as what you wanted.

To revert this setting -- same approach as described, but delete the 'nomodeset' from the quiet splash line ... same save, same update Grub and reboot.

did not work for me

did not work for me again

Strange because the esc key or the left shift key should open the grub menu before splash screen. This should work.

WHAT did not work ? Just follow the instructions. Did this on my laptop and it works fine .

show me a video of it

I tried on my hp desktop with old graphics it was my first pc ever. you can save me a video of it. there was no safe graphic.

… use google and do some search on that.