Satisfactory with an Arc GPU

Greetings,
I have issues with some games and my Intel Arc GPU. One of that games is satisfactory.

I've installed the official intel arc drivers from the intel documentation.

I tried to use -USEALLAVAILABLECORES and or -vulkan

Using -vulkan, the game starts but freezes after 3 seconds in the loading screen. I need to kill it.
Removing -vulkan, the game does not start at all.

I also tried to use multiple Proton versions via steam.

  • GE-Proton8-30
  • Proton Experimental
  • Proton 8.0-5
  • Proton 7.0-6
  • Proton 6.3-8
  • Proton 5.13-6

But yeah, none of them resolved my issue. Some of them lead to different behaviors. Like, the game starts to the loading screen and never stops to load.

The last thing I tried is to uninstall vcrun2022via protontricks since some players on protondb mentioned that. But without luck.

One of my friends also uses Linux, he can play satisfactory with GE-Proton8-30 without issues, but he has an NVIDIA gpu. My guess is that satisfactory does not work well on linux with the arc gpu. That would make sense, since some players that can't run satisfactory and report that on protondb, also use either an intel igpu or an arc GPU.

1 Like

Perhaps changing to a higher kernel might improve things?

I recently updated the kernel to 6.5 via the Software Updater. The post you linked seems to use 6.4
I am not sure if I have enough self-confidence to upgrade to a newer kernel version, but I could try it.

You could try it with Ubuntu Mainline. It is a Tool with a graphical Interface to install newer Kernels. Maybe this makes it a little bit easier for You?

Oh indeed, that tool makes it easy to install a newer kernel

I installed 6.7.3 and then restarted the laptop, that worked according to uname -r 6.7.3-060703-generic
But that sadly did not fixed my problem

1 Like

I have been using Steam without ever having any problems.
Until about 5 months ago.

I have been consistently on Zorin OS 16.3 the entire time.

Some months ago, Steam games randomly stopped launching. I ended up completly wiping and purging Steam in order to resolve it. With a lot of web searching, I found many threads from Windows and GnuLinux users alike complaining about Steam Games suddenly failing to launch, as well.

I never did solve all issues and to this day, Astroneer will not launch as I sit at the back and watch updates and additions go by.

Greetings

Every other game works fine in steam, only satisfactory not. Some players think that's a "new" issue with the Unreal Engine 5 update (Satisfactory 8), and intel arc
I can play my other games very well (at least the games I tested) without any stability issues or low performance, only satisfactory sadly refuses to start

I just give it a try at a later point of time, maybe with new graphic drivers a new kernel version or when a new satisfactory version arrives

Or someone maybe has experience which this specific issue
And one thing I forgot to mention, this is the hardware of my notebook

Asus UP6502
12th Gen Intel® Core™ i7-12700H × 20
Mesa Intel® Arc(tm) A370M Graphics (DG2) / Mesa Intel® Graphics (ADL GT2)

Okay. That is sad. Maybe it is a Driver Problem or a Problem with this special Game.

I hav an Idea what You could try but I don't know if you want to make the Circumtances. I've heard about Nobara Linux. It is a Game-focused Distro based on Fedora. It has optimized Kernels. Maybe this works for You.

Thank you for the recommendation

But that's okay now, I just have zorin on my laptop and I don't play too frequently on it. It's more programming and production for work/school

I still can play satisfactory on my pc

1 Like