Scarlet 4i4 No microphone sound imput

Hi !
This is the first time i'm trying linux full time, but there's one final problem i need to fix first.
I have had a Scarlet 4i4 for a while now but now i have installed zorin, the sound output works no problem but i dont have a mic imput anymore. Does anyone know if i can fix this. I have heard that Scarlet dont have any linux support whatsoever but i also heard that scarlets usualy at least have working imputs/outputs.
Thank you very much.


you may first want to try alsamixer and see if the mic is muted or sset low. Open the terminal and type:


If after playing with alsamixer you still have mic problem, post a screenshot of your alsamixer showing "All" sound channels.
That will help any further investigaton.

Thanks for the help,

I tried putting everything on max volume just in case and switched between line, rear mic and front mic.
But the thing is it's technically on the audio interface just as my headphones, the whole thing is connected via USB.
Discord Mic
Also this is the text discord shows me as a device name which is odd and maybe helpful.

OK. Now seen Scarlet 4i4 USB sound "box" on Amazon and understand more what you have got there.

A couple of things to try:

In alsamixer unmute those Mic items marked "M". Scroll across using arrow key and hit M key to unmute.

Also in alsamixer toggle Auto-Mut(e) to set Disabled.

Do you have another sound card installed? If so in alsamixer hit [F6] to show soundcards and make sure correct one is selected.

It may be the case that your Scarlet 4i4 sound card/box is not (yet) supported by linux kernel or available drivers.

EDIT: If Scarlet 4i4 has Realtek ALC1150, there seems to be a driver here: Realtek Alc1150 Ubuntu

EDIT2: Also see this:


I tried un-muting everything it didn't change anything, so i downloaded and installed both .deb files and i can see some of those were indeed installed in the right folders (i think). But the Scarlett.conf doesn't exist.

And alsa still says the same thing on both the standard page and the Scarlet page.
Screenshot from 2022-01-19 19-21-17
The realtek driver i think is doing something but since i don't have anything plugged into the motherboard sound IO i cant confirm.
I'm pretty sure i didn't understand properly how to install the drivers so i will be checking again in a bit.
Thanks for the help ! Pretty sure it's almost done.

So i finaly worked out how to install the drivers, only thing is i still have no sound. So i guess i know need to play with the settings till something works

Another shot would be Pulse audio control app;

sudo apt install pavucontrol
1 Like

OK so i know Managed to have the mic direct on headphones, but it still doesn't input to the system and i also lost sound, and for some reason installing the driver disabled my second monitor. But other than that getting closer to a working thing.
I tried pulse audio, but it doesn't really add anything new yet. IL keep trying.

Screenshot from 2022-01-20 11-04-05
So that's the settings so the full size jack at the front will allow system sounds.
Now just need to make the mic work to

So i did more testing my picture settings was wrong so here is a good one
Screenshot from 2022-01-20 11-30-50
Now in terms of microphone. The current problem seems to be that input+output doesn't work properly, so when i am in output + multi input i have sound but no mic, and when i use just multichannel input i have working microphone

Hmm i don't know what i did differently but by activating standalone and deactivating it again i just fixed it and it works. So thank you very much for the help, I think a combination of the Scarlett driver [zabadabadoo] found Pulse audio fixed it.

1 Like

Marked Solution. 302

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.