Scrcpy worked with u?

I don't know why that app doesn't work with me, i did all steps, enable usb debugging mode in my mobile and connect ,but it show always device offline

adb server version (41) doesn't match this client (39); killing...
* daemon started successfully
adb: error: failed to get feature set: no devices/emulators found
ERROR: "adb push" returned with value 1

Have you tried accessing the device by wireless using wifi debugging? Are the drivers for your device installed (not all devices are recognized and have drivers)? Without accessing adb, can you access and traverse the phones contents by usb or wifi/Bluetooth? Does adb devices require you to authorize the connection? Do you have the latest SDK platform-tools installed?

A little more information than, "it doesn't work", would be helpful.

no, i think that anthor problem here, my usb cable can only charge my phone when link usb in pc, even if i changing the usb mode, so i think i can't connect with usb

to connect by wifi, i need first to connect with usb in the initialization.
if i want to get the initialization without usb, i need to pair phone with pc by enabling wireless debugging,the version of adb in zorin doesn't have option of pairing

I think scrcpy need to adb version 39 which zorin has it,but doesn't support adb pair, adb version 41 has pair, but can't support scrcpy

ok, i solved it , i didn't need to using usb , i installed adb last version 41(which has pairing) beside the adb version of zorin 39,

eid@eid-HP-Compaq-6005-Pro-SFF-PC:~/platform-tools$ ./adb connect  192.168.1.5:39409
connected to 192.168.1.5:39409
eid@eid-HP-Compaq-6005-Pro-SFF-PC:~/platform-tools$ ./adb tcpip 39409
restarting in TCP mode port: 39409
eid@eid-HP-Compaq-6005-Pro-SFF-PC:~/platform-tools$ adb connect  192.168.1.5:39409
adb server version (41) doesn't match this client (39); killing...
* daemon started successfully
connected to 192.168.1.5:39409
eid@eid-HP-Compaq-6005-Pro-SFF-PC:~/platform-tools$ scrcpy
INFO: scrcpy 1.12.1 <https://github.com/Genymobile/scrcpy>
/usr/share/scrcpy/scrcpy-server: 1 fil...shed. 0.4 MB/s (24773 bytes in 0.055s)
INFO: Initial texture: 720x1520
1 Like

i tried another USB cable which enable data transfer and worked good without internet, so u should sure that USB is for data transfer, if not u can use my method in the solution which u must pair phone with pc using the command of adb pair <ip address phone>