Screen Brightness doesn't work

I'm new to Zorin OS and i have a persistant problem on my Custom made laptop.
i have this config, with a Geforce rtx 2070 Mobile.

I see all the brightness option in the setting, also with the keyboard shortcut, but they don't change anything at all. the Brightness is always to the max.
The wierd thing is that i had that issue also on my two previous OS (Ubuntu 21 and the last Pop OS). Windows doesn't do it better.

I tried to reinstall/delete the driver, but is doesn't work.

If someone knows anything, it would be realy helpfull.


You can try follow this article :

Or this

Try and see..

If not, we can try something else.
I had same issues before

Thank you for your respond. I tried all the 4 possibilities.

The second and the last one worked for a few day, but now its also not working anymore. I don't think i realy install or did some update on purpose in between.
For the 4 one, i get this result :

chalkos@chalkos:~$ xrandr | grep " connected" | cut -f1 -d " "
xrandr: Failed to get size of gamma for output default

The second link, I didn't realy anderstant what i hade to change, since I have an AMD processor, with a Nvidia 2070 Mobile (its only for Intel i think).

The wierd thing its realy that it also don't work on my Windows boot (i also tried there a lot of stuff). The only time it works, is during the linux installation process. Maybe its something wrong with my hardware ?

Thanks a lot for your response

You could install xbacklight package
sudo apt-get install xbacklight
and then if you want to increase the brightness level, type
xbacklight -inc <level in a range of 10 - 100> and vice versa:
xbacklight -dec <level in a range of 10 - 100>

I have same issues when I am using WM (Bspwm) , probably it is due to some package, driver, kernel or who knows.

So than only control via terminal helps