Screen freezing when lock screen

I just get a new computer and I installed Zorin OS lite. All if fine except when I press super + L for lock screen it doesn't go to login screen but simply kind of freeze screen and I can only move mouse cursor

You might try

sudo apt install --reinstall xfce4-screensaver


sudo apt remove xfce4-screensaver

Reboot and test

It doesn't change anything. Weird thing is hour in taskbar does change while "frozen" so I have no idea

It looks like lock is triggered but login page is not.

What happens if you run in terminal;


It does same, weird thing is my mouse cursor still update if I move it on terminal window's corner or on text field

sudo apt install --reinstall zorin-os-lite-desktop

What is the output of

uname -r

sudo lshw -C video

This was reinstalled with success but doesn't fix

Output 5.15.0-75-generic


 *-display NON-RÉCLAMÉ     
       description: VGA compatible controller
       produit: Intel Corporation
       fabricant: Intel Corporation
       identifiant matériel: 2
       information bus: pci@0000:00:02.0
       version: 00
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list
       configuration : latency=0
       ressources : mémoireE/S:600-5ff mémoireE/S:400-3ff mémoire:6000000000-6000ffffff mémoire:4000000000-400fffffff portE/S:4000(taille=64) mémoire:c0000-dffff mémoire:4010000000-4016ffffff mémoire:4020000000-40ffffffff

Your display shows as Unclaimed - it has no loaded driver.
What graphics card are you using?

I have graphic card embed into processor but it is Intel UHD Graphics 750MHz and processor is Intel Alder Lake N95

And my monitor is connected to my computer using HDMI cable

Can you run

sudo apt install linux-oem-20.04d

Reboot and test...

Sadly install works fine but it doesn't fix

Is display still unclaimed?

Yes all same, if it can help here is the computer Trigkey Green G4 Mini PC/Intel 11th Generation Processors N100/16G DDR

I upgraded all still not, I have no additional driver available

It may be a lengthy output... But you can run


and paste the output here (Or use

It doesn't exist I guess you meant dmesg so here is output

Yes, I meant that. Sorry. It was pretty late here...
I have gone through the log but it shown nothing that can explain this.

Have you tried a higher kernel?

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.02

Reboot and test.

1 Like

It did work! My computer is very recent with some components from 2023 like the processor so it might be the reason. Thank you so much :slight_smile:

1 Like