Screen Glitching in OBS Studio

Hey, recently I just downloaded OBS Studio because I want to record a video. But I just realized that my screen glitches whenever I am recording. (The screen doesn't glitch, but video came out glitching)

Can you please relay your terminal output for

sudo lshw -C video

Graphics faults can cause this.

description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:600-5ff iomemory:400-3ff irq:155 memory:601c000000-601cffffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

I got a string of code. Does this mean anything?

In your OBS Studio settings, does your video output settings match the resolution listed above?

Are you logging in on Wayland or X11 Desktop?

When did you last update your system and which version of OBS studio are you using?

sudo apt update && sudo apt full-upgrade

I would also take a look at an alternative screen recorder, vokoscreen recorder usually works well and is what I have used for recording my desktop for tutorial videos for my Vimeo account after processing in KDEnlive.

I'm sorry, I don't understand by Wayland or X11 Desktop, how can you tell if I'm using a Wayland or X11 Desktop? I used OBS Studio version 29.1.3 and I actually just installed Zorin OS so I haven't update anything just yet.

Oh I recognize the problem now. I thought the problem is fixed using vokoscreen recorder, but everytime I use 60 fps, the screen still glitches.

i had a similar issue. can you play this video on your phone or any other device? it could be an issue with the video player or media codecs.

In reference to:

I guess check that resolution refresh rate matches, too...

X11 is the standard Windowing Protocol and Wayland is an alternative to it.
You can run the following in terminal:


To check which you are using.

I recommend running your updates:

sudo apt update && sudo apt full-upgrade

1 Like

Essential to run upgrades on any OS's.

Also try "GPU Recorder" from the software center. I use it for my recordings.

1 Like

Problem solved, it is not the problem of the recorder but the VLC Media Player, I reinstalled VLC Media Player and it worked. Thanks for all the people who helped me!


Just to add I have experienced similar glitches but on second run fine. I used Winff to convert .mkv to mpeg-4 but it only produces 360p resolution on upload to my Vimeo account. Swapped for the .mkv file and now get full 1080p resolution on Vimeo. I also used mpv player to watch the video instead of VLC which only appeared to play sound.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.