Screen lock doesn't consider web media playback

I updated zorin 15.3 (gnome) with the newest kernel (and other system updates). but after restart when watching videos on amazon it locks the screen after the set up time. what has changed and what can be done to avoid the screen locking while watching online media?

This guide may help:

1 Like

but why is it happening now? it didn't until this update

I'd have to check what was updated on 15.3... But if the screensaver package was updated, it may have reset the config file to Default Timer.

maybe this can help you:
Start-Date: 2021-09-27 16:30:00
Commandline: aptdaemon role='role-commit-packages' sender=':1.837'
Install: linux-image-5.4.0-87-generic:amd64 (5.4.0-87.98~18.04.1, automatic), linux-modules-extra-5.4.0-87-generic:amd64 (5.4.0-87.98~18.04.1, automatic), linux-headers-5.4.0-87-generic:amd64 (5.4.0-87.98~18.04.1, automatic), linux-modules-5.4.0-87-generic:amd64 (5.4.0-87.98~18.04.1, automatic), linux-hwe-5.4-headers-5.4.0-87:amd64 (5.4.0-87.98~18.04.1, automatic)
Upgrade: linux-headers-generic-hwe-18.04:amd64 (5.4.0.86.97~18.04.77, 5.4.0.87.98~18.04.78), linux-image-generic-hwe-18.04:amd64 (5.4.0.86.97~18.04.77, 5.4.0.87.98~18.04.78), linux-generic-hwe-18.04:amd64 (5.4.0.86.97~18.04.77, 5.4.0.87.98~18.04.78)
End-Date: 2021-09-27 16:30:51

The kernel- but then, the kernel is a large Hardware Driver package... Who knows what in there caused Screensaver to revert. As long as you can adjust it, should be no problem. Personally, I disable mine.

after doing another restart it seems to have returned to the old behaviour. and that caffeine thing came in handy

1 Like

I just use xset s 0 0 on my build and never use the screensaver, at all.

what's this one?

If you run xset s 0 0 in terminal, it sets all timers to never for screensaver.

1 Like