Screen refresh difficulties

Good morning again, ladies and gents.

Another issue came up on my Zorin 16 build on a Lenovo 9i Yoga Slim.
The screen seems to be stuttering a lot when scrolling (I seem to get horizontal breaks in the screen, this not only happens on firefox, but also in e.g. the settings menu.). I have tried changing from x11 to Wayland to no avail.

Additional info:

  • Stuttering seems less when changing to a lower resolution, 4k capable screen, currently running on 1980x1080
  • Refresh rate is 120hz capable on 1980x1080 but on 4k its capped at 59.9hz?
  • The PC has the Intel XE graphics, which might be causing the scrolling issue? When trying to reinstall with safe graphics it does not seem to have the issue.

Thanks again, my dearest PC wizards.

This might be one of those cases where you need to turn on V-sync. to syncronize your computer's refresh rate with your display.


Ok, modified the document, but PC is now extremely unresponsive.
Wallpaper also changed, and looks like the attached photo:

Please help lol

1 Like

You should be able to just reverse what you did, remove what you put in the config and return to normal.

I'll have to hand this one to @Aravisian cause I have 0-clue what to do at this point.


I'm going to do a fresh install again, with secure boot disabled and intel special something enabled?
This with secure graphics enabled, as I think all of the issues mentioned with this laptop might have something to do with the boot settings.

1 Like

Darn, didn't help. Are there proprietary drivers for Intel XE graphics or something?
Added a video of the issue: VID_20211003_085238
PS, this happens on X11 and on Wayland.



helped me with the following comment:

The Ubuntu Forums has a good description of how to install/update the Intel graphic driver in Ubuntu.

Extract of the pertinent part is as given below:

  1. Open a terminal session by pressing CTRL+ALT+T
  2. Run command to install ppa:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
  1. Install the drivers for your graphics chip
sudo apt-get install xserver-xorg-video-intel

Ubuntu no longer uses xorg.config file. You will have to create this file in the next step and enter in values.

Create file sudo -H gedit /etc/X11/xorg.conf and edit it

Section "Device"
Identifier "Card0"
Driver "intel"
Option "AccelMethod" "sna"

The stuttering is resolved, but when I open some graphical application like firefox, it is a slow as excuse my language, thick ■■■■ through a thin tube. And i am unable to change my resolution.

1 Like

I want to issue a sincere apology for the bad advice I provided earlier, I feel really bad about that. I was just trying to help, and this is the first time that I can recall, where my advice ended up in someones system getting locked up.

Believe it or not, this has happened to me before, and its not a fun experience. Often it requires entering safe mode, and fixing mistakes, or applying resolutions. So again I apologize.

I am happy to know however, that you were able to come up with a solution, and I want to thank you for posting that solution. Usually, with the Intel GPU, the driver is already loaded for it in the kernel. But my experience with that is of course Intel HD and Intel UHD.

Intel XI graphics is a brand new type of GPU that is most recent, so I have no experience with that. This is why I always advocate having multiple people on tech support, from different areas of expertise, and different machines to test on.

I realize things are not perfect for you right now, but after my last dobocle, I am hesitate to provide anymore advice, as I do not wish to risk locking up your system again or worse. Just know I feel for you.

And even though your system is not perfect right now, I am going to give you a stellar rating for the self solution, (well mostly solution) and the posting of it here. You are amazing! :star2:

1 Like

@StarTreker Hey! Don't worry! :smiley: You tried to help me to the best of your knowledge, and I want to make sure you know that there are no hard feelings whatsoever! I am not expecting magic from forum users and I know that everyone tries their absolute best! If you have any more suggestions, I would feel honored to try them out.

All the best :wink:

1 Like

@StarTreker, I have found something and I hoped you could help me out :smiley: Apparently it is inherent to Lenovo laptops to have issues with newer kernels. According to a stackexchange forum user,

They had a way better experience by rolling back to a 5.8 kernel instead of 5.11. Do you have a guide handy to start this process? As I can't seem to find much info on how to do this as a linux "noob" :slight_smile:

Fellow ZorinOS users, and who knows maybe someone in the future, at this time Lenovo does not like the 5.11 kernel. A downgrade to 5.8 seems to resolve ALL issues that I have mentioned:

Non working keyboard
Bad working touchpad
Weird horizontal screen flickering when scrolling/ moving the mouse

Hope this was informative

Yes actually, this is a guide on how to install the 5.8 kernel on Ubuntu 20.04, which is the version that Zorin OS 16 is based on. So theoretically, the process should go well.

Thank you for posting that info, we've had more then one user on this forum having issues due to the kernel. Kernel issues make me mad, you know that? lol

1 Like

Well, that didn't help either. I think I'm gonna give up :slight_smile:

Well, hold on, I want to know something first, otherwise I am not convinced.

CTRL ALT T to enter terminal.

uname -a

Post results, I need to know which kernel version your system is running. Because if its not 5.8, then all you did was install 5.8, but haven't selected it at boot in GRUB.

Well, I tried loading it up under different kernels, but those kernels also bring other problems with them. Both 5.8.0-050800-generic and 5.8.0
-63-generic don't give me the option to connect to the internet, also my idiotic keyboard and mouse still won't work :slight_smile:

The one time my touchpad worked, was when I opened 5.11 and accidentally removed the kernel with my sudo apt remove 5.11

So yeah, I'm at the end of my rope :smiley:

Let me rephrase:

5.8.0-050800-generic: EXTREME screen tearing, cannot do anything, when I move my mouse, my whole screen is flying all over the place, like an epileptic seizure :smiley:

5.8.0-69-generic: doesnt allow me to acces internet, also very non-functional in other places

I'll just tie a knott at the end so you don't slip off.

Alright, which Linux are you gonna try next? Don't lie to me now, cause I'll know when you are. Maybe Fedora? Debian based distro's?

Haha no worries, you actually lighted the fire again, I think I can do this!

I am able to move around the flashing screen to get into the system, hopefully you can help me! I'm going to make a quick video

As promised: VID_20211003_172354 flashing happens when moving the cursor :slight_smile:

I am good at that arn't I? Igniting the fire that burns within ones soul. Now, you go ahead and make your video, that way hopefully somebody else can help you like Aravisian, or one of the other mods. I can't be up 24-hours, so I will be going to bed.

Thats right, I'll be counting stars till I fall asleep. :night_with_stars: <<<--- See, lots of stars :star2:

1 Like

Sleep well, and thanks for all the help! :slight_smile:

Found this after a websearch. Don't know if it will help or not as many others reporting flickering or flashing, but no real solid answers anywhere.
This suggests trying Wayland.

You have marked one of your posts as "Solution". Is that still true?