Screen remains blank after wake up from suspend

When I close my Laptop (HP Pavilion g7-2318sz) and reopen it later on sometimes:

  • the screen remains black
  • or I see the login screen shortly but then it turns black
    I press the on button several times and sometimes the login screen stays visible and I can login again. Then often the screen slightly flickers for 5-10 minutes and is ok then.

Mostly I have to full restart again because the screen remains black. All issues are gone then.

Probably an issue with my graphic card (AMD Radeon HD 7420G Discrete-Class)

It seems to be a know Ubuntu Issue. There are some hints, but no one did work: https://askubuntu.com/questions/1032633/18-04-screen-remains-blank-after-wake-up-from-suspend#:~:text=When%20your%20screen%20is%20blank,%2B%20F3%20(wait%20a%20second)

Hi placid-c and welcome to the forum! See if the solution offered here works for you:

I tried to sudoedit /etc/default/grub
to set GRUB_CMDLINE_LINUX="nouveau.modeset=0" and sudo update-grub reboot, but did not help.
I did not understand how to switch from lightdm to gdm3. Gnome screensaver seems already to be installed and running.
The only change: The Screen is flickering more then ever before. It clams down after a while…

I then installed xscreensafer. It does not run automatically. By starting it manually the problems kept the same… No difference if it is running or not.
Pressing on/off Button 2-3 times kept the only solution.

@placid-c just to be clear, are you running Core or Lite version of Zorin? Thanks.

Just a couple of comments. I had Lite on a laptop and it never showed me a screen. I just entered the password into the blank screen and it worked.

I recently installed Zorin on my desktop and tried out Weyland. I had all kinds of problems with wake up and other things and gave up on it and went back to x11.

1 Like

placid-c, if you are using Zorin Lite (XFCE):

You will want to keep lightdm and not switch to gdm3.
If you like, you can remove xscreensaver.
Suspend is not moderated by the screensaver, but by the power saver. Ultimately, it comes down to three different pieces all trying to control the same function.
If you use screensaver (Which I think unlikely since you installed xscreensaver trying to find a solution), then this may cause your screensaver to not work.
But, in terminal, please enter

xset s 0 0

Please open your Power Saver manager from your settings and ensure that “Screen Blank after” is set to “never” and so on for each setting.

Once again, back into the grub, change your line to:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_sleep=nonvs”

Then save and exit (ctrl+x, then hit y, then hit enter to keep the same file name).

Then

sudo update-grub

After a reboot, please post back results…

I’ve had issues with booting or resuming from sleep with an AMD laptop when on battery. starting up or resuming whilst plugged in seems to not have the same issues.
I have seen elsewhere that it’s a bug with Linux and AMD processors on battery.