Screen switches back and forth between full resolution and 1280p

So I just installed a AMD Radeon HD 8570 and my resolution keeps jumping back and forth, during the initial boot, and inside the os, if I try just plugging the display into the port on the computer without the graphics card it works fine, if at a lower resolution, it also seems to switch when I try and get into the display setting, but it gets suck on the lower resolution mostly.

I'm running Zorin os 16.2, I just ran every update available, but still no luck, any ideas what's the problem here?

There are a few things you can try to fix the problem with your resolution jumping back and forth on your Zorin OS 16.2 system after installing an AMD Radeon HD 8570 graphics card.

1. Check your graphics card drivers

The first thing you should do is check to make sure that your graphics card drivers are up to date. You can do this by going to the website of your graphics card manufacturer and downloading the latest drivers for your specific card.

2. Update your BIOS

If your graphics card drivers are up to date and you're still having problems, you can try updating your BIOS. Your BIOS is the software that controls the basic functions of your computer, and it's possible that an outdated BIOS is causing the problem with your graphics card.

3. Disable your integrated graphics

If you have integrated graphics on your motherboard, you can try disabling them to see if that fixes the problem. To do this, go to the BIOS and look for the option to disable integrated graphics.

4. Use a different graphics card

If you've tried all of the above and you're still having problems, you may need to use a different graphics card. It's possible that your AMD Radeon HD 8570 is not compatible with your Zorin OS 16.2 system.

Here are some additional troubleshooting steps you can try:

  • Try using a different display cable.
  • Try changing the resolution in the BIOS.
  • Try updating the BIOS to the latest version.
  • Reinstall the graphics card drivers.
  • Contact the manufacturer of your graphics card for support.

I am not as familiar with AMD on Linux as I am Nvidia. So this may not be helpful but I would go into the “Software and Updates” application and then the “Additional Drivers” tab and see what alternate drivers are available.

From what I understand the open source drivers are usually good for AMD but I think what I said is worth a shot.

Yeah I checked there, and it says I'm not using any propitiatory drivers, it's just blank

I am curious myself if this is related.

Could be, but it does work sometimes, and it's a bit more stable after a few restarts but it still freaks out sometimes, so it party works but something is off.

Is this your only graphics card or are you running a Dedicated Radeon and an integrated Intel graphics chip?

These drivers are included in the Linux Kernel. Changing the kernel to a different version (In other words, changing the drivers) may be what is needed.
What is your output of

uname -a

Linux zorin-HP-Compaq-8100-Elite-SFF-PC 5.15.0-73-generic #80~20.04.1-Ubuntu SMP Wed May 17 14:58:14 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

I believe that this is the latest available from Zorin.

Your AMD Graphics card is on the older side... So an earlier kernel would probably be a better fit.
Can you post the result of the terminal command:

xrandr --listproviders

Providers: number : 1
Provider 0: id: 0x53 cap: 0x9, Source Output, Sink Offload crtcs: 2 outputs: 2 associated providers: 0 name:OLAND @ pci:0000:01:00.0

Does using a older kernel make me loose access to any features?

It would be very unlikely. The only way that could happen would be if you put an older graphics card into an otherwise very young and modern computer.

Ok, so AMD Radeon is your only card.
From Boot > Advanced Options for Zorin
Which earlier kernels have you got installed? (You might just boot the earliest one and test how it works...)

where do i find that menu?

And thanks for all the help!

1 Like

Actually, after a few restarts, it seems to be stable, now, I've probably restarted it at least 15 times now, and I'm not having any issues, but I'll give an older kernel a go if they pop up again. Thanks for all the help!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.