Screen tearing when playing local files

Recently installed Zorin Pro 16.1 on a machine of mine. Everything works great except for the screen tearing that happens when I watch a video. Screen tearing occurs through VLC and SMPlayer (with mpv backend). I've tried every possible setting through these programs to help fix the issue, but nothing seems to work. I even tried the method of creating a 20-intel.conf file with "TearFree" but that also didn't help. Luckily, there doesn't seem to be much of an issue when watching videos on the internet. I also don't experience screen tearing when scrolling or moving windows. So I'm not really sure what to do here.

I don't have any issues when I use Linux Mint. Playback is smooth. The main difference that I see when I run inxi -G is that Linux mint has "modesetting" for the driver, whereas zorin has it as "i915". I have no idea if that's really the issue, but I just know that Linux Mint seems to work better when playing videos.

Any tips on how I can fix this?

Here is my info:

System:
  Kernel: 5.13.0-37-generic x86_64 bits: 64 compiler: N/A 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 Distro: Zorin OS 16.1 
  base: Ubuntu 20.04 LTS Focal 
Machine:
  Type: Desktop System: Dell product: OptiPlex 5070 v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Dell model: 0YJMC0 v: A01 serial: <filter> UEFI: Dell v: 1.12.0 
  date: 12/10/2021 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510 
  serial: <filter> charge: 55% (should be ignored) status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360 
  serial: <filter> charge: 55% (should be ignored) status: Discharging 
CPU:
  Topology: 6-Core model: Intel Core i5-9500 bits: 64 type: MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36000 
  Speed: 899 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 899 2: 900 
  3: 900 4: 900 5: 900 6: 900 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e92 
  Display: x11 server: X.Org 1.20.13 driver: i915 compositor: gnome-shell 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.6 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Device-2: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-10:6 chip ID: 046d:082d 
  Device-3: Schiit Audio Schiit Modi 3+ type: USB driver: snd-usb-audio 
  bus ID: 1-3:3 chip ID: 30be:1014 
  Device-4: Samson Meteor condenser microphone type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 chip ID: 17a0:0310 
  Sound Server: ALSA v: k5.13.0-37-generic 
Network:
  Device-1: Intel Ethernet I219-V vendor: Dell driver: e1000e v: kernel 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bc 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 121.16 GiB (13.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST31000528AS size: 931.51 GiB 
  speed: 3.0 Gb/s serial: <filter> 
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 
  bus ID: 00:17.0 chip ID: 8086.2822 
Partition:
  ID-1: / size: 915.40 GiB used: 121.13 GiB (13.2%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 291 Uptime: 4h 42m Memory: 7.55 GiB used: 2.75 GiB (36.5%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 

This is an interesting observation. You can try testing it...

sudo nano /etc/default/grub

Arrow key down to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Add the parameter i915.modeset=1 to make it:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1"
ctrl+x to exit, then the y key to say yes to save, then the enter key.
The terminal will revert to normal. Run

sudo update-grub

Now, run

sudo apt update && sudo apt upgrade

Reboot and test...

Thanks. I actually did a little research and came across a gnome extension "disable unredirect fullscreen windows." Surprisingly, this actually seemed to cut the tearing down a lot. There's still slight tearing, but it's so minimal that that it doesn't bother me anymore.

I will keep your suggestion in my back pocket in case the issue persists. Thanks again!

1 Like