Screen tearing with intel drivers

Issue only occurs in X11, and not wayland. It happens only in full screen. i tried adding an 20-intel.conf in /etc/X11/xorg.conf.d/ but that just made the issue way worse and i had to delete the file.

What is the output of

sudo lshw -c video

   description: VGA compatible controller
   product: UHD Graphics
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 02
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:138 memory:d0000000-d0ffffff memory:c0000000-cfffffff ioport:3000(size=64) memory:c0000-dffff

Not unusual on this chip - UHD620?
I have heard the problem is absent in KDE and XFCE desktop.
I am not sure why.
But if the "tearfree" trick did not work, I am not sure what else to suggest.

one time after a restart my screen had black pixels in a pattern all over, and another time half my screen would just turn black

in that case, you might try:

sudo apt purge xserver-xorg-video-intel

sudo reboot

and test...

omg i can't believe this worked! thanks so much!
P.s - the problem still persists in the native video player (which i don't use)

Nvm, it's back :frowning:
The tearing isn't as bad but still prominent

I use a conky to monitor my RAM, so I know when it starts to fill.
It also reports and GPU and on CPU usage.
I think we may need to work a little harder to narrow down your cause.
https://www.makeuseof.com/fix-screen-tearing-on-linux/

Yup. So how do I get Vsync?

I believe that Vsync is part of Nvidia driver packages. If you are not using Nvidia card, then that portion would not apply to your machine.

The only remaining option from the site is to update my drivers, which I assume are automatically on the latest version, right?

Usually... It depends. Some cards work better with older drivers - so which you are using depends on which card you have. Jockey (Additional drivers) checks a "Recommended" list to determine which drivers you use, if using the Automatic Install (Or using "sudo ubuntu-drivers install" command in terminal, for the Nouveau drivers).