Screen turning off Zorin OS 16 Core

I am looking at some of the settings in Zorin, trying to configure it so that the screen doesn't turn off the instant I lock the machine - yes its minor and its an OCD thing of mine I confess, but I can't seem to find a way to stop the screen from going off right away on locking.

Under Screen Lock settings I have thus:
Blank screen delay - 15 minutes (I assume blank screen means to turn it off)
Automatic Screen lock - Enabled
Automatic Screen lock delay - 30 minutes
Lock screen on suspend - Enabled
Show notifications on lock screen - Enabled

Under Power Settings, I have the following settings:
Blank screen - 15 minutes
Automatic suspend - Off

None of the settings I play with stops the screen from instantly turning off when I lock the machine, sadly.

Any ideas?

Thanks

When I lock my screen, the screen does not immediately turn off. It shows the Lockscreen, instead.
My settings (on the Gnome build) and on my regular use build are pretty much identical.

When you lock the screen, does the monitor shut off completely? Do you need to hit the power button on the monitor in order to see the lockscreen and enter your password? Is it a notebook or an external monitor?

When I lock the screen, it goes off straight away regardless. Behaves the same on both my PC with external monitor, and my laptop with its inbuilt screen.

I have to tap the keyboard to get the screen to come back on and pop my password in.

1 Like

I am using XFCE, not Gnome, so that may explain the difference. Testing on Gnome shows that it does as you describe. The monitor is not fully powered off... But in sleep mode.

I logged into Gnome again and checked Settings- but I do not find anything there that does what you want. I opened dconf-editor, and navigated to /org/gnome/desktop/session because this is where a delay for the lock screen used to be... But I only see the delay for when it kicks in on its own.
Lockdown also lacks that setting.

I am honestly not sure how to achieve what you are looking for, aside from altering the code that governs the screensaver app.

Oh well, never mind then. I guess its something I will just have to get used to I suppose :slight_smile:

I dunno if I am out of line for asking but... uh... What is it exactly that you want the monitor to do?

Just not turn off right away. I don't mind if I'm away for a bit and it goes off after 15/20 minutes or more. Its not major like I said, just a bit of an OCD thing on my part ahah :smiley:

Ok, in this case, do not use the Lock Screen keyboard Shortcut or menu button.
Instead, set the Delay on the Lock (screensaver) and then let it lock itself after that amount of time. I think that is your solution- Don't hit the command for it to lock right away.

With the timer set in your settings, if should auto-lock fifteen minutes later.

If you have blank screen enabled, then the screen will turn off. I always thought that the term blanking in Linux was an absolutely horrible word to describe the obvious, SCREENSAVER! Blank means screensaver, its the same thing. But somebody in the Linux development thought it would be cute to call it blanking.

So, short answer, if you don't want the screen to well blank, disable blank.

1 Like