Screensaver not working on Lite

I’ve just installed Zorin 16.2 Lite 64 bit on an old Toshiba Tecra.

The problem is that the screensaver is not working, however I try to adjust the settings in Power Manager or Screensaver the screen goes black after 10 min’s. (I’ve also just installed 32 bit Zorin on another laptop and it’s affected by the same problem.)

I tried using this command but to no avail.

xset s 0,0

The ‘Caffeine’ apps are supposed to prevent PC’s from falling asleep.

I installed ‘Caffeine’ and ‘Caffeine Indicator’ apps from the software repository. The ‘Caffeine Indicator’ is supposed to activate the app whereas ‘Caffeine’ restores the screensaver. They don’t seem to work. I wondered if that might be because the apps in the repository are outdated so I tried to install the latest version from the terminal using the commands below but the results are the same.

I right clicked on ‘Caffeine Indicator’ and clicked on ‘Open with Create Launcher on panel’. This created an icon [3 x backwards slashes] on the right side of the panel. When I right click on that icon ‘Launcher’ is greyed out.

It seems then that the app can’t be launched.

Has anyone got any suggestions?

I used the commands below from the link here to try and install the latest version of Caffeine.

sudo apt update

sudo apt install caffeine

If you want you can get the latest version of Caffeine by adding the developers’ PPA repository

Open a terminal and run

sudo add-apt-repository ppa:caffeine-developers/ppa

sudo apt-get update

Then, if you already have Caffeine installed:

sudo apt upgrade

But if you haven’t installed it:

sudo apt install caffeine

REMOVE

In the terminal, execute the following command:

sudo apt remove caffeine

If you have installed Caffeine using the PPA repository, you may also want to remove the PPA from your list of software sources.

In that case, run these commands:

sudo add-apt-repository --remove ppa:caffeine-developers/ppa

And then,

sudo apt update

1 Like

Remember to change settings on Settings > Privacy > Screen Lock as you like.

Thanks for your reply but there is no ‘Privacy’ icon within Settings in Zorin 16.2.

You did me a favour by directing me too Settings because it was only then that I noticed something rather odd, which is that there are 2 x ‘Screensaver’ icons within Settings. When they’re opened one is titled ‘XScreensaver 5.42, 28-Dec 2018’ and the other simply ‘Screensaver’. They’re different from one another.

I disabled them both and this seems to have solved the problem.

1 Like

Sorry, maybe you don't see it named Privacy, that's what I read :point_down: (Italian).


No, GNOME and XFCE (what lite uses) have different settings interfaces. This is the settings app for XFCE:

xfce-settings-manager

1 Like

Please correct me if I'm wrong, but I quite remember that Caffeine is specifically a Gnome Extension. So if you use Zorin OS 16.2 Lite which is using XFCE desktop environment, you can't really use it or maybe will face problems when you want to use it.

1 Like

@Tecratonic. There is the Caffeine Gnome extension and also Caffeine app, which was in Software Store.
See this: Remove blank screen after inactivity - #4 by zabadabadoo

Although I have used Caffeine on Windows, I have not on ZorinOS.

If you have Lite (XFCE) then see if the Caffeine app, (not the gnome extension) will work. Let us know the result, as do not know if successsful or not from that other thread.

1 Like

I attach a screenshot of ‘Settings’ on my installation of 16.2 Lite 64 bit.

As you can see there are 2 x Screensaver icons (and also 2 x Desktop icons). Perhaps something went wrong during the installation.

As I stated previously the 2 x screensavers are slightly different to one another. I disabled both of them which seems to have solved the problem. I think Caffeine couldn’t work on this PC because it’s designed to disable 1 x screensaver but my version of Zorin seems to have two!

I also installed 32 bit Zorin on another laptop. The screensaver also seemed to be dysfunctional. There is just 1 x Screensaver icon in Settings. I used the

xset s 0,0

terminal command and this seems to have disabled the screensaver.

1 Like