Screenshot froze me out of Desktop

Apps running:

  • Discord
  • Steam

I was on Xorg and on voice-call with friends on Discord, telling him about proton so they could play games. The problem occurred when I was taking a screenshot of the compatibility window.

Nature of the issue:

  • other than the Start menu, cannot exit out of screenshot or interact outside of it
  • can move and resize the selection panel
  • cannot interact with the screenshot options button

Actions taken:

  • tried desktop shortcut, nothing
  • tried opening system monitor through menu, nothing happened
  • tried log out and restart through menu, cannot interact with the selection tool
  • force shutdown and restart, solved

Now, either I will switch screenshot app or never use it. Also screencast does not work either

I'm not sure about the rest, but these two issues in particular are known but haven't been properly addressed yet. You can try gnome-screenshot to use the previous version of the screenshot utility, and use something else for screencasting like OBS. Both should be available through the Software Store.

how do I set this as default when taking screenshots?

You'll have to overwrite the default keyboard shortcuts inside Settings -> Keyboard -> View And Customize Shortcuts -> Custom Shortcuts:

1 Like

gnome-screenshot --interactive doesn't work well with me, but after digging for some other commands, I went with gnome-screenshot -a for screenshot selection

Alright, that's a temporary fix for the screenshot issue. Though, the main concern is that if it happens again [The whole screen freezes and you can't close out of anything for using the built-in print screen feature], I tried pulling up a log of the error from syslog. I found some error logs that felt off for me.

Would it be okay to put it here?

Sure, maybe there's something that points to the issue but I can't make any promises. Like I said, these two issues are known and related to the default screenshot utility. Using something else shouldn't cause any problems.

When you paste the logs in here, please make sure to type triple backticks (`) – that's the typically found below the Esc key – before and after. This will format it nicely so that it's easier to read.

It should look like this.

1 Like

In case OP is willing to try something else other than the default screenshot tool. Flameshot is worth a mention, its a must-have for me ^^

I had problems with the standard application for recording screen videos. The problem was resolved after reinstalling Zorin, but it reoccurred.

I installed the "GPU Screen recorder" and it is working perfectly.

The log was too long for it to be posted so I uploaded it to this link.

It looks good, but can't install it without the kde framework, I'll look into it in a bit.

I would love to know the command lines to setup a shortcut for screen recording.

Sorry for being a pain, but is there any chance you could upload to something like https://paste.debian.net instead of Google Drive?

When you install from the Software Store you will usually have multiple sources to choose from, under the Install button. In your screenshot you have selected "Snap Store".
For most software, I would recommend using the native package format when possible, which is labeled as "Zorin OS". I speak from experience.

Follow the same steps as for the screenshot. By setting the same keyboard shortcut you will effectively overwrite the defaults, but you can also set whatever other combination you like.

3 Likes

Aah, you can do what zenzen mentioned about it above, or try installing with apt. Which is what i prefer. Apt is just so reliable.

As per image, you can install flameshot with

apt install flameshot

1 Like

No worries, here you go

1 Like

Thanks for suggesting flameshot! I gave it a try, although it doesn't have the selection tool command (or couldn't get it to work) for custom keybind, it has a lot of useful options that could help me a lot later on. Until I figure out how to make full use of it, I'll be sticking to gnome-screenshot with selection tool.

Flameshot doesn't automatically bind the printscreen tool, since some keyboards doesnt have it. So you just bind it yourself by going to Settings in the OS > Keyboard and add a custom keybind.

flameshot gui

If you're having trouble with the keybind, you can enter the command into the terminal to see if it activates flameshot.

1 Like

Thank you, and apologies... I'm not really sure if that even shows the real problem. On a fresh new virtual machine, the logs I get are different:

JS ERROR: TypeError: this._pipeline is undefined
stopRecording@resource:///org/gnome/Shell/Screencast/js/screencastService.js:185:9
StopScreencastAsync@resource:///org/gnome/Shell/Screencast/js/screencastService.js:493:18
_handleMethodCall@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:368:35
_wrapJSObject/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:401:34
run@resource:///org/gnome/Shell/Screencast/js/dbusService.js:186:20
main@resource:///org/gnome/Shell/Screencast/js/main.js:13:13
run@resource:///org/gnome/gjs/modules/script/package.js:206:19
start@resource:///org/gnome/gjs/modules/script/package.js:190:8
@/usr/share/gnome-shell/org.gnome.Shell.Screencast:1:17

This is the relevant bit that is reported by journalctl -xe just after stopping the recording. I tried both on Wayland and X11, with no difference in result, although X11 produced a different log message:

Can't update stage views actor <unnamed>[<MetaWindowActorX11>:0x5f6139580f30] is on because it needs an allocation.

And then it wouldn't even start up, showing simply this message:

Error starting screencast

On Debian 12, running the same version of Gnome, it works fine. This makes me think that something about how Zorin OS implements the Gnome desktop is causing the issue.

1 Like