Scroll bar moves to where I click

This does not behave like windows 10 or mac in scrolling. How do i change this? I am using zorin 17 core...

Do you have a touchpad? If so, go to Zorin menu > Settings > Mouse & Touchpad, and under Touchpad, enable Edge Scrolling.

Now, rather than clicking on a scrollbar to scroll, you just drag your finger along the right-hand vertical edge of the touchpad and it scrolls smoothly. If you feel it scrolls in the wrong direction (up when you pull your finger down or vice versa), disable Natural Scrolling.

I'm doing more research on making Linux smooth-scroll when clicking the scrollbar, like Windows does.


Ok, try this:
sudoedit /home/$USER/.config/gtk-4.0/
-- or (if you don't have sudoedit set up to use gedit yet) --
sudo gedit /home/$USER/.config/gtk-4.0/

Add the following line under the [Settings] header:

Save the file, exit the editing program, reboot the computer and let me know how it works.

The file was blank so I tried creating the settings header then I added gtk-primary-button-warps-slider=0 ..rebooted... but it still behaves like before. I used zorin before and I recall creating a settings.ini in the same folder with the gtk-primary-button-warps-slider=0 but maybe that was in zorin lite..why am I missing the file I wonder..

Thanks for your help, for now I have found a workaround in firefox I added a flag to about:config ui.scrollToClick as integer with value of 0

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.