SD card failiure?

Hello, I recently got a new laptop and wanted to give Linux another shot, so I flashed a microSD card with Zorin OS Core 17.1 and booted from it. It checked the file system and said that there was 5 errors found, which was worrying but I couldn't stop it. It then proceeded to say 'Installing NVIDIA Drivers... this may take a few minutes." It was stuck on this screen for 25 minutes, so I made the mistake of forcibly turning off my laptop.
Everything was okay, apart from the microSD card. When I attempted to re-flash, I was met with balenaEtcher saying "Flash failed.". If I tried to format the microSD card from the Windows Explorer it says "Windows was unable to complete the formatting". Trying to run chkdsk from the command prompt states that the card was in RAW format, so it cannot check the disk. Have I killed my microSD card? My laptop model is an ASUS ROG Flow X16 if that helps.


I know a Rasperry Pi can use an SD card to boot from but usually not for a a regular distribution. Just because you can does not make it a reliable way to go about it. A good quality USB thumb drive or flash drive is a better option that can handle the extreme writes and reads to a better degree. Thumb/flash drives are not that much better and I am certain there are some SD cards that perform better than a USB thumb/flash drive. Also, how old and/or used is the SD drive? This kind of memory has a limited number of writes and the smaller the drive, the smaller amount of writes available. I would try again from a USB memory stick and then reformat your SD card. That is the only thing I can think of. Per Zorin, an SD card is not the recommended way to install their OS.

I dont know also but when when format your sd card there is option of quick format you can try unchecking that. Now it will take som more time to format it. You can try again now. Hope this works. Sorry if it doesn't

I used to run Zorin OS as the drive for this SD card and it worked fine, but I think I might have to buy a USB drive then... That very well could've worn down the SD card.

Tried it, didnt work. Thank you for the suggestion though!

You could try it with diskpart on Windows. It is a Command Line Tool but for this it could be a good Solution. So, type in the Search Bar diskpart and make a right-click on it and choose ''Run As Administrator''. That is an important to do because You need Administrator Rights to do the Following.

When it is open type list disk and you will get a List with Drives. Unfortunately there are not named. There are only Numbers. Now you must see were Your SD-Card is. You can find it when You look at the Capacity. The GB-Sizes are shown. So You must take that with the Size from Your SD-Card. When you founded it look what Number it has.

Then You type the command sel disk [Number-of-Your-Card]

Then the Drive is choosen. Then You type clean and with that Command it will completely delete. So BE CAREFUL what You have chosen!

After that type create partition primary

After that type format fs=ntfs quick

And then it is formatted to the Standard NTFS File Format. To change it in FAT32 you can make it now in the windows Explorer like normally.

Attempting to use the command 'list disk' gives me this error:
"'list' is not recognized as an internal or external command,
operable program or batch file." (I did use the administrator version, I checked)

EDIT: Nevermind, I used the regular command line instead of Diskpart... Anyway, it seems like that didn't work either. It says access is denied, although I did run it as administrator.
"DiskPart has encountered an error: Access is denied.
See the System Event Log for more information." (This is after trying to run clear."

Checking the Event Viewer (which I assume is what it is referring to) says this error... hmm..

I can make you a pictured Step-by-Step Guide if You want. Maybe it is clearer than. But I take some Time. Maybe tomorrow Evening.

In common I would recommend to use a USB Stick. You don't need a big One. 8GB are enough.

Update: I've come to the conclusion that the card is dead.
After inserting it into a chromebook I had, it contained all the normal ZorinOS files but was locked into read only mode. I tried to remove it, but nothing. This happens after an SD card is almost dead, so you can retrieve the data from it before its gone.
RIP. I'm going to go buy a USB stick.

You don't need to:

That doesn't mean that it must be broken. It was made from Etcher like this. I have that too when I use an USB Stick. I give You later a little Guide like I wrote. Of course You don't must try if You not want. But when it works You don't have to throw the Card in the Trash.

I may be way off, but are you using a SD Card adaptor? I only ask because I once had a similar issue, turns out the 'Lock' tap/switch was moved accidently by my handling it, with fat


Okay, I will try to show a little Guide like I wrote. But You should definetly look for @JeffK969 's Suggestion. Sometimes the small Things make big Trouble. But if that is okay and You want to try it, is here my Step-by-Step Guide:

You start in Windows and search for diskpart and make a right-click on it an choose the Option to run it as Administrator (I know it is german, it is only for Orientation):

When the Diskpart-Window is open You type list disk and You should get a List of Devices:

In my Case there are only 2. 0 is my internal m.2 and 1 is a USB Stick that I use for this Demonstration. In your Case could it be look different. It depends how much Devices You have. As you see, there are no Names to identify. So you must look at the Sizes of the Devices. So, I know, I must use Number 1. To choose it, You type sel disk [Number-of-Your-Device] In my Case it is sel disk 1. Then it looks like this:

You get a Notification what Device is chosen. And now it is important that You have chosen the right Device because in the next Step it will be deleted so LOOK TWICE that You choose the correct One. Okay, now You type clean and then you get this:

After that Your Card should be cleaned. Then You type create partition primary and then it should look like this:

After that You type format fs=ntfs quick to format it for first Use:

So, after that you can close diskpart and go into Windows Explorer and make a right-click on your SD-Card and choose the Option to format it and format it to FAT32 and done.

I hope that I explained it good enough and it works for You.


Balena Etcher has a bit of history wrecking USB sticks, so I guess also SD cards. But you may be able to resuscitate that SD Card, so don't bin it just yet.
Maybe consider using a different USB tool in future, e.g. Rufus, Unetbootin.

I'm not, but thank you for the suggestion!

1 Like

Yes, I exactly did the steps of this guide however it still didn't work.

How would I resusciate it? I only used balenaEtcher because thats what the install guide recommended... (I do still have the card)

Thank you for the suggestion, and this does seem as though it'll work, however I've already ordered the USB stick.. and it seems a lot easier to do it that way

1 Like

See Aravisian past #4 and Zorin devs post #5 here: