Second Internal Hard Drive Not Showing

Greetings - yet another new Zorin user, and somewhat-new Linux user. I used Linux many years ago with RedHat and Suse but now I'm trying to get back into it. Recently installed Zorin 17 Pro. On this laptop I have an internal SSD, around 250GB, and a second internal 1TB Samsung SSD, as well as one external 2TB Samsung SSD.

The issue, or what seems to be an issue is in Files under "Other Locations" all I see is Computer. I don't see the second internal drive. The external drive is mounted and accessible at the bottom of the left hand side.

However, if I go to Computer, then media, I see the contents of the second internal drive. This seems odd to me, as I expected the second internal drive to be mounted and accessible as a separate drive. As I came from Windows it is in NTFS format, as is the external drive.

Any suggestions? It would seem to me something isn't mounted right. lsblk -f returned with this:

NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
loop0 squash 4.0 0 100% /snap/bare/5
loop1 squash 4.0 0 100% /snap/core22/1122
loop2 squash 4.0 0 100% /snap/gtk-common-themes/1535
loop3 squash 4.0 0 100% /snap/makemkv/624
loop4 squash 4.0 0 100% /snap/snapd/21184
sda
├─sda1
└─sda2 ntfs SAMSUNG 64F6794AF6791D8C 500.2G 46% /media
sdb
└─sdb1 ntfs T7 EXT DA70464670462999 1.1T 39% /media/chris/T7 EXT1
nvme0n1
├─nvme0n1p1 vfat FAT32 9015-8C9D 504.9M 1% /boot/efi
├─nvme0n1p2 ext4 1.0 887ffaa7-c51e-4667-8f01-973e89439500 1.2G 18% /boot
└─nvme0n1p3 crypto 2 0c6f3f06-a7e6-4577-8947-cb5cea31423d
└─nvme0n1p3_crypt
LVM2_m LVM2 wMfdpj-SJo2-lxfK-vftt-C8B0-1xSM-nOB4Ld
├─vgzorin-root
│ ext4 1.0 22de95e7-9296-486e-a448-2d6715519c09 182.5G 15% /
└─vgzorin-swap_1
swap 1 1c52650e-ba30-48de-90fc-6eb42a753620 [SWAP]

Hi, and welcome!

This looks odd to me:

sda
├─sda1
└─sda2 ntfs SAMSUNG 64F6794AF6791D8C 500.2G 46% /media
sdb
└─sdb1 ntfs T7 EXT DA70464670462999 1.1T 39% /media/chris/T7 EXT1

One of the partitions from one drive (sda2) is mounted inside another drive (sdb1). While technically possible I can't think of any reason why you'd want to do this.

First, unmount the drives: sudo umount /dev/sda2 /dev/sdb1. And let's take a look at the output of cat /etc/fstab.

1 Like

This is normal. It is mounted Media and therefor, accessed through that organized file tree.

I use the Nemo File Manager on Zorin OS, not Nautilus (the default file manager), so in my left pane, the additional drives are listed and accessible with One Click.

One option to adapt the desktop to your workflow may be to use a file manager that fits your workflow style.

1 Like

Agreed, that is what it looks like. When I ran the umount it gave me this:

umount: /dev/sda1: not mounted.
umount: /media/chris/T7 EXT1: target is busy.

And then with the cat /etc/fstab it gave me:

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/dev/mapper/vgzorin-root / ext4 errors=remount-ro 0 1

/boot was on /dev/nvme0n1p2 during installation

UUID=887ffaa7-c51e-4667-8f01-973e89439500 /boot ext4 defaults

Thanks, I just installed Nemo to see, but it still does not show that internal drive. Under Devices in the left pane it only shows the external drive.

Welcome to the Forum!

Maybe the System don't like the NTFS-Format for an internal Drive.

Make sure you don't have the file manager accessing any of the files inside the drives. Same thing on the terminal, otherwise it will report it as in use and cannot be unmounted. Then you should be able to unmount the drives.

Now that I think of it, the unmounting the drives might have been because of the order since one of the partitions is inside another... Let's try one at the time:

sudo umount /dev/sdb1
sudo umount /dev/sda2

Assuming this works (verify again with lsblk that these drives are not mounted anywhere) you can now create separate directories for each drive.

mkdir -p /media/<your_username>/SAMSUNG
mkdir -p /media/<your_username>/T7_EXT1 

Notice that the second command does not have spaces for the drive name. Space characters in file names are a frequent source of annoyances; better to avoid them.
By the way, you can pick whatever names you want for these I'm just using the names of the drives as they appeared in lsblk, again for better organization. Here's a screenshot of me be not following my own advice, just to prove that the name is not that important, and as an example of how it might look:

Then you can mount the drives each in its own directory:

sudo mount /dev/sda2 /media/<your_username>/SAMSUNG
sudo mount /dev/sdb1 /media/<your_username>/T7_EXT1

At this point we might want to look into editing the /etc/fstabentry to ensure the drives always mount to the same directories. But let's see if this all works first.

2 Likes

Screenshot from 2024-03-14 17-16-05

That certainly seemed to work! I can now see both the internal and external drives under Devices in Nemo.

Great! In theory that's how it should be mounted automatically so I'd just leave it for now. But if you want you can update the entry at /etc/fstab to enforce this. Add a line at the end that looks like this:

UUID=C0A271C1A271BD0A /media/zenzen/TOSHIBA_EXT ntfs defaults 0 0

This is using my own external drive so you'll need to update the UUID, mount point and file system. To find out the UUID you can launch Disks, select the drive and the partition in question:

It's important to understand that this UUID corresponds to the file system i.e., one per partition, not the entire drive. Just something to consider when you have several partitions in the same drive. Also, if you reformat the drive or the partition at all this UUID will change and you'll have to update the /etc/fstab entry.

Again, this is not necessary as it should be done automatically. But if you notice that the drives are mounted in odd locations after rebooting at a later time, this would enforce the mount locations.

1 Like

I agree here is my SSD Win 10 Drive showing up on Nemo .....

Got it, and again many thanks for the education and help!

1 Like