Separate audio outputs on a dual monitor setup


Recently installed Zorin 16 Pro and loving it so far, I’m new to Linux wanted to move away from Windows 10.

I have a dual monitor set up both with audio outputs using an MSI 1080ti. Within windows I can set different applications for sounds via sound mixer.

Monitor 1: (Skype calling, alerts from a website using Opera)
Monitor 2: (For anything else)
Both connected via DisplayPort.

How would I go about setting this up? Any help would be grateful.


You seek Pulse Audio Volume Control

Find it in the software center you will!

Star Treker Your Wise Tech Support Guru

1 Like

Hey StarTreker,

Thanks for your reply.

I downloaded Pulse Audio Volume Control.

Within the configuration setting i can see both monitor outputs but only able to sync one HDMI at a time. anyway to configure both (HDMI) and (HDMI 3)?


I believe that you can only choose one HDMI output at a time. I realize you were asking about auto switching between apps, but I don't believe this is a function that Linux has, but I could be wrong.

What I thought you would find useful however, was the ability to choose your output, and the ability to adjust the individual volumes of each app that is currently playing sound, its a very useful feature.

Unless I am mistaken, I think that Pulse Audio is the most powerful utility for sound. You can also install the Pulse Effects APP, which adds great functionality to you, you might like that one too.

And you can also get a sound output chooser extension to allow you to choose input/output settings and volumes from your taskbar too.

1 Like

I prefer Alsamixer with PulseAudio removed (Uninstalled).

1 Like

Thanks for your help all, can see that Linux doesn't like dual HDMI outputs like windows. Can switch between them i guess.

After a few hours playing around managed to get my sound card (Sound Blaster Z) working with speakers and headphones after installing Alsamixer to enable headphones.

1 Like

Save that Alsamixer setting using:

sudo alsactl store


Thank you

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.