Settings doesnt open

i tried sudo apt install gnome-control-center --reinstall but it doesnt work. earlier i was trying to remove some leftover desktop files of uninstalled apps whose icons where still showing in applications menu and i also tried removing them frommain menu.
upon running gnome-control-center, i get this response.

i tried using timeshift to go back to a previous backup but it didnt help either.
please help ASAP.

Maybe this simple approach could work ....

sudo apt purge gnome-control-center

sudo apt autoremove && sudo apt autoclean

sudo apt install gnome-control-center

Try in the terminal to open the settings-manager by using sudo

sudo gnome-control-center

If this does not work ....... you may have to purge the entire desktop and reinstall the Gnome-desktop completely. Make backups of stuff you need before you try this. The reason behind this heavy reinstall is actually simple: you may have conflicts inside the hidden files of your /home - folder. You can try to remove config-files and some mix ups .... but a reinstall of the desktop is a much faster approach and you get a fresh restart. If the polution in the system is even more than the D-E only, a fresh install of Zorin will give the least headaches.

Running apps is fun, but always be prudent what you install and what the apps do on a system, technically I mean, ..... so no : it always does matter what you do and how you do it.

1 Like

Now it opens in terminal using sudo but not through the app icon. i think ill have to reinstall the whole desktop completely. can you please share the command for reinstall of the whole desktop, so that i wont make any more errors? thanks

it shows this upon using sudo gnome-control-center

1 Like

it doesnt work even after reinstalling desktop

@Aravisian can you please look into this ?

Well sadly this was to be expected in a way .....
Drastically reinstalling the D-E solves the problem ...
But first you could try via the settings manager (opened as sudo then) to delete your inlog-account and create a fresh new account (user I mean) granted ALL administrators rights ..... Not 100% shure it will work, but you can try it at least as first step. Why ? It works in sudo , so it should work as user as well .... and it could be the permissions in the users account is off-set.

Drasticly installing the D-E is a 100% good method I guess.

sudo apt purge zorin-os-desktop

sudo apt install zorin-os-desktop -y

Don't forget to make a brand new administrators account or a users account with admin's rights. You could break the entire system on doing this little D-E reinstall.
At the other hand ....... Why not FRESH install a brand new Zorin Core OS ? I think this will give for you the least of problems after the changes you make.
Zorin can be installed again as many times you want, there are no restrictions involved like this is with Microsoft's Windows. Don't forget that good aspect of Linux. We all had this on our hands in the beginning days of Linux lol ..... no shame, no game lol

1 Like

how to reinstall whole zorin os core ?

The same way you got it installed it in the first place .... ?
Download Zorin Core OS
Make a bootable USB stick
Boot the Stick out of the bootloader BIOS.
Make sure to select 'Wipe the disk and install the OS'

Really nothing to it.

ohh.. i dont have any usb with me rn.. i lost the last one i had :((
ill try doing it when i have one.. for now ill just try your last method..
thanks so much for helping out.. i shouldnt have acted stupidly and deleted the wrong thing..

1 Like

Well calling it stupid is no good for your mental health.
You try things, things went wrong ..... so revamp the system with a fresh one.

Create always a Linux Toolbox you always carry together with you computer or laptop: 1 stick as the OS you have installed, 1 stick with an ISO from Gparted, 1 stick for FreeDos 0.1, a open spaced stick for emergencies and a generic WiFi-dongle for saving you out when onboard WiFi gives out. This toolbox cost you really no more than a small 15€ or Dollar. AliExpress is ideal for buying those things.

So ..... If you do not have a stick maybe a friend got one or a family member ....?

1 Like

i have it at home but i am out till 2nd march.. will have to wait i guesss..

i just did the removal of old user acc and made new acc.. i think it worked, everything is fresh here.. should i still do these commands:

sudo apt purge zorin-os-desktop

sudo apt install zorin-os-desktop -y


1 Like

You could try the account switch as last option that is safe to do.
So go to the settings-manager via the Terminal and open it as sudo gnome-control-center.
Go to the settings of USER (at the bottom of the list) / Unlock the screen / Make a FRESH new account and give it all administrators rights .... Be smart for renaming it differently than the original and use the very same password.
After the creation of that new account ----> log out / log back in with the FRESH new account and as first step try your settings-manager via the Zorin global menu.
If it works --> delete the old account that gave a lot of problems.

Another idea is to delete all hidden SETTINGS-files inside your /Home - folder.
Press Ctrl+H to unhide them and use your common sense a lot ..... I can't say what is ok and what not --- that depends a lot on your system only.

No if it works you are LUCKY now !!!! no use of those commands anymore

thanks sooo much man..

1 Like

You make an old man like me sweat a lot lol .......

Happy for you it worked out ok !!!!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.