Settings not Open on Zorin 16

Halo again to my zorin forum,

This my 2nd trouble when try this zorin, after first try on Zorin 15 finally I test to Zorin 16... it's a nice looking but suddenly Settings app cannot open... and say Settings is not responded
I already try to remove and install again but with no luck, with this command,

sudo apt-get remove unity-control-center
sudo apt autoremove
sudo apt-get install unity-control-center

Any suggestion... @Aravisian :grin:

Zorin os is not using unity control center. It uses gnome-control-center.
I think you should try this:

sudo apt purge gnome-control-center && sudo apt install gnome-control-center


Thanks for answer but problem still there...

1 Like

Do you remember whether you made any change before this happen? Did you take any updates?

You should purge unity.
It will not work on Zorin.

Already do any update...
Just try Mac OS look and Windows 11 look and when I open settings to back to Mac OS again, settings is not responded that's an option Wait and Force Close

Did you remove unity?

What will happen if you type
gnome-control-center in terminal?

I think I don't remove unity
I will remove it first

1 Like

So Zorin uses Gnome-Control-Center?

controls your settings.

Type it in terminal and see what will happen.

The same if I click Settings

Already purge Unity now try

sudo apt purge gnome-control-center && sudo apt install gnome-control-center

1 Like

Zorin uses gnome-control-center
to control settings.

Now you can open the settings, your problem is solved?

Wait still try to install Gnome-Control-Center

Try sudo nautilus /usr/share/themes and remove Windows 11 look folder.

Had you installed the Unity Desktop? You would remember doing it if you had.

If you press alt+F2, a launcher will open. Enter into it gnome-control-center and the Settings Manager should open.

I had similar issue, but in zorin os 15.3 lite. I changed icon theme to Fluent and zorin dock gone, so I could open xfce settings in terminal just with sudo, but I couldn't change icon theme there, so I deleted Fluent icon theme in /usr/share/icons and everything worked fine.

1 Like

Yes, I try it just like the first post and then I remove it...
Finally I know what the culprit is... Display on Settings...
If I open Display on Settings and it shows not respond... so I restart it and open Settings again because the last time settings open in Display it shows again Not respond. So I have to force close to quit, and then I open Wifi Setting in Right Top Bar and settings could open just fine...
I suspect that because Variety app... so I remove Variety and open Display on Settings can open with no problem...

1 Like

I use Zorin 16 Pro

I also had a problem with Variety when I was using Mint Linux. I never tested it on Zorin.

1 Like