Setup zorin lite without password

So I have an ongoing project were I am setting up a dashboard on several TVs and every setting Is set up and automated. Example If the power goes and comes back It sets everything back to normal again.
There Is only one issue, the login.
Since this is only to show information in a chrome page It seems impossible to skip password. I tried disabling the password, but It still wants someone to click "login" on the login page and asks for password right after.
I also tried creating a new user without password but It sets it disabled then and requires password to enable user.
So my question Is. Is it somehow possible to bypass the login screen in Zorin Lite?

I think Zorin Lite uses XFCE so your process might be a little different from mine since I believe XFCE uses Light Display Manager (LightDM). Whereas I'm using Gnome Display Manager ver. 3 (GDM3) for Zorin Core (Pro).

That said, if I wanted to do this on GDM3, I would probably want to edit the /etc/gdm3/custom.conf file. It has sections which can be un-commented and set up to allow automatic login, among other options. I would imagine Lite has the same type of file.

For GDM3, use your favorite editor to edit the file, like so: sudo vim /etc/gdm3/custom.conf. You can also use nano or gedit in place of vim.

  1. Edit the line under the [daemon] header which shows a commented-out "Enabling automatic login" and its two options: AutomaticLoginEnable = true and AutomaticLogin = user1.
  2. Uncomment both by removing the hash sign, and change user1 to your username.
  3. Save and exit.
  4. Restart the GDM3 service: sudo systemctl restart gdm3.

For Lite, the same principle applies: sudo vim /etc/lightdm/lightdm.conf.

  1. If commented out, uncomment the "Seat Defaults" header and options.
  2. [SeatDefaults]
    autologin-user=<YOUR_USERNAME>
    autologin-user-timeout=0
  3. While there is not an "AutomaticLoginEnable" boolean expression to change for Lite's .conf file; if autologin-user-timeout is set to 0, it means there's no timeout, and the system immediately logs in without waiting.
  4. Save and exit.
  5. Restart the LightDM service: sudo systemctl restart lightdm.

Test it out and see if that's what you need!

Doesn't Lite have Automatic Login option like Core?

Wow. Good point. I don't think I've ever paid attention to that part of my Settings application. Looking now, I do see the Automatic Login toggle - but I've never used it. I can't say for sure though, if Lite has the same toggle.

For the OP as a reference point:

1 Like

I seem to recollect that lite also has the automatic login. Used lite a couple of weeks ago, so doubt that this is the mandela effect.

Yes, Zorin OS Lite includes automatic login.

I would not recommend using it on any distro, Lite Core, or otherwise... But it does exist.

Why not? For privacy reasons?

Privacy and security do matter, but the actual reason I wouldn't recommend it is that the Auto Login causes a variety of other bugs and issues all on its own.

2 Likes

Where can I read to know about these bugs and issues?

I am not sure of a direct resource you can go right to; But you can look into autologin with System Suspend, Lockscreen issues.
It will interfere with Samba and on Zorin OS Lite will interfere with Thunar.

1 Like

I have seen many issues reported on the forum in the past that relate some way to Automatic Login being used. If you search the forum, you will see for yourself.

Another time saver that causes grief is setting grub timeout to zero.

Please avoid if you want a quiet life :slight_smile:

2 Likes

From what I read in search results on the forum the option gives problems in many contexts.

Just checked and none of these are available for me. The closest I can see is lightdm-gtk-greeter and users.conf. But none of the text you mentioned unfortunately.

This is not available on the light edition. I have a different view and It seems like this option is not included.

Can you try

sudo touch /etc/lightdm/lightdm.conf

sudo nano /etc/lightdm/lightdm.conf

Replace $USER with your actual username:

autologin-user=$USER

Tap ctl+o to overwrite, then enter to save configuration, then tap ctl+x to exit the editor.

Reboot and test...

I managed to fix this issue by creating a file called lightdm.conf adding the contexts:

[SeatDefaults]
autologin-user=add your username here
autologin-user=timeout=0
user-session=ubuntu

after saving moving it over to /etc/lightdm/

After a hit a wall with chrome asking for a keyring password, so I had to remove the files in youruser/.local/share/keyrings/

Now It works like a charm :slight_smile: