Sgx disabled by Bios

Hi.
I have had zorin lite installed for two months and it works great for me.
I have it on dual boot with windows.

Today I tried for the first time to boot via windows. There was a strange sound. Switched of the computer, turned it back on, tried to get back to Zorin and then that message came and I'm unable to get to my Zorin session which is a bit of a problem as I have all my work in it.

Here's what is say's.

Thanks for your help.

I'd be interested to know what kind of strange sound was made this could be a hardware issue unfortunately however let's troubleshoot it as computer just crashed and it's just software related in a dirty dismount.

I would get your zorin CD or USB boot into live mode and then run the fsck check from there that way file system check will have full access to the entire drive.

1 Like

The SGX diabled by BIOS and the AE_NOT_FOUND error can be ignored.

The issue you are having is a corruption has occurred on your nVME drive, that has damaged critical system files. This may be physical failure to a tiny component within the drive or it may be a failed write to the drive.

The prompt is making suggestions on what to do - it sugggests running a manual File System Check (FSCK) on the drive.
Type exit at the prompt where it says (initramfs) and please relay the results of that here.

to run fsck, check which partition you need to run it on:

blkid

Then run the fsck command Replacing the PARTITION-ID below with the actual partition ID you got from blkid above:

fsck /dev/PARTITION-ID -y

Here's what it says.


Which one of the 5 partition id's should I copy?

Your ext4 is on nvme0n1p5.

You may want to see @seanhinkley 's post above about booting LiveUSB to run fsck on your install of Zorin OS with the drive unmounted.

Your command should be

fsck /dev/nvme0n1p5 -y

SGX is Intel Software Guard Extensions and used by some corporate software. its like a protected mode for vendors so their code is hidden and secured in an enclave.

Looking at the screenshot you want the first one, the 'ext4' /dev/nvme0n1p5
For explanation:
ext4 is a linux partition
vfat is the efi partition (boot files)
the rest are ntfs (NT file system) - Windows partitions.

Right, so when I type in the fsck command, it says the partition cannot be found.

I reinstalled Zorin, now it works (I had most of my work on a drive).

Thanks for your help.

1 Like

Looks like it didn't recognize the command as there should be a space after fsck - just look for that in the future if you ever need it.

sh: fsck /dev/nvme0n1p5

1 Like