"Show Applications" - can this be changed?

Hello

I'm aware that there's a post on here from a few years ago, but it seems that no solution was offered.

Can someone please tell me how to customise the "Show Applications" menu? I love the layout of Zorin in general, but this menu is my least favourite aspect of it by far. I don't find it nice to use and I'm not even sure how things are ordered in there. It appears to offer zero customisation, out of the box.

To be clear, it's the menu that shows you all of your installed applications when you press the nine dots on the taskbar (or at least that's what I do on my setup):

I'm a total Linux n0ob, so please bear that in mind :smiley:

Well, what kind of customisation do you want? If you want it to go away that is easy enough but I suspect you already know how to do that.

That is the activities overview.
The Activities Configurator gnome-shell-extension may help you to customize it. Be sure to select shell version 3.38:
https://extensions.gnome.org/extension/358/activities-configurator/

That sounds like what I need. Unfortunately, I haven't a clue how to install it. I've downloaded the file and end up here:

No, I don't know how to do that. I don't really want it to go away, as much as be replaced by something better / be able to customise what I already have.

Place the extracted file in ~/.local/share/gnome-extensions

If you do not see the .local folder in your home folder, tap ctrl+h keyboard shortcut to reveal "hidden" files.

Ah, how did you know to do that? Unfortunately, I don't see the gnome-extensions folder :frowning:

Sorry, I apparently didn't know how to do that.:stuck_out_tongue:
~/.local/share/gnome-shell/extensions

I do not use gnome, so I forget gnome specific things sometimes. Your screenshot helped.

Haha! Ok I got a bit further, but don't see the extensions folder:

Create a new folder named extensions if it doesn't exist, then place the downloaded and extracted extension within that directory. (There is also a Root extensions folder in which the default gnome extensions that came installed with Zorin OS are currently placed. /usr/share/gnome-shell/extensions).
Once done, open gnome tweak tool

sudo apt install gnome-tweaks

Or
Zorin Settings
and navigate to the extensions tab to enable it.

I've done all of that, minus the last step. I can't find the extensions, sorry :neutral_face:

Tap alt+F4 and enter in
gnome-control-center
Once launched scroll down to the Extensions tab.

Or

sudo apt install gnome-tweaks

Launch Gnome Tweaks from app menu once installed (Search as tweaks) and then move to the extensions tab.

Alt-F4 closed my window. Was that the intention?

gnome-control-center opens the settings screen:

ummm alt+F2
It was a typo.
I am on a roll today.

Yes, that is Zorin Settings. I do not see extensions, either...
I use Zorin OS Lite which is XFCE, not Gnome. I do not use Gnome...
Please try gnome-tweaks, instead. I am more familiar with it (at least my memory of it is better...)

You're almost looking as bad as me haha (joking - by a long way!)

I think I've made progress again, but the Applications Menu hasn't changed after enabling the Applications Menu slider:

Did you activate the Activities Configurator extension?

Wouldn't it be easier to install firefox Gnome Extensions plugin and enable the extension on the Activities Configurator extension site?

Probably, but I am not well versed in that process and I'd make a bigger mess of it.

@total_linux_n0ob install gnome extension plugin for firefox and thereafter go to Activities Configurator - GNOME Shell Extensions and switch the on/off/install button in the upper right of the page.