Shutdown taking too long and wifi troubles

Hello! I've recently upgraded from Zorin OS 17 to 17.1 and I'm having troubles with it:

  1. Shutdown taking too long: before upgrading my laptop shutdown in like 10 secs, but now after 7 mins nothing happens. I can see the Zorin OS logo on the screen, but it stays there until I force shutdown in with the power button. Later on I tried to connect back to a Wifi with the settings app, but it took long to open too and It said something like "Networkmanager has to be running". I think it crashed somehow.

  2. Wifi troubles: after upgrading I can't seem to turn off the wifi nor turn on airplane mode. I can disconnect, but I can't connect back. I click on the Wifi I want to connect to and it does nothing, so I have to restart my laptop. Strangely, If I switch from Wifi 1 to Wifi 2 it does that with no problem.

Quick edit: When I shutdown my laptop I waited for errors and I got this:
spi-nor spi0.1: Software reset failed: -524
spi-nor spi0.0: Software reset failed: -524

Later on I added "acpi=force" to my grub config (GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force")
but it didn't help. Can someone help me?

Zorin 17.x is a fork of Ubuntu 22.04 (Jammy Jellyfish) and I suspect is a bug related to 22.04:

With respect to shut down times:

In terms of networking issue, take a read of this please:

Hi swarfendor437! Thank you for your reply! I will try to fix the Wifi bug later on today, however I visited the the other sites which you mentioned, but I didn't seem to find a fix for the shutdown problem. Did I miss something?

Also, I've tried editing the system.conf file. I've set DefaultTimeoutStopSec to 20s and I've added ShutdownWatchdogSec=20s but nothing has changed so far.

Sorry, think I posted wrong link on shutdown!

Hi again. Just wanted to let everyone know that this problem got fixed with an update. Or at least for me. Still, thanks for the help! ^^

1 Like