Sleep / time out settings not being respected

I set my "when inactive for" in system on battery and plugged in to never, i turned the screen saver off, ive set the display power management off for both on battery and plugged in, but still after a few moments my screen still greys out, what am i missing?

In terminal, please run

xset s 0 0 && xset -dpms

If after rebooting, the problem returns, add the above command to the end of your ~.profile file. That will ensure it stays permanent.

That fixed it, much appreciated.

There is probably a setting in GUI somewhere... I keep forgetting. But the above I remember. Go figure...

It works exactly the same since the GUI app sends the same command.