Slow boot and an odd warning: ata1.00 Read log page 0x00, Emask 0x04

I apologize for not having the full warning/error, I tried a few times to take a pic but my timing is off.

when i enable ahci i get this behavior after install. i cant find anything about a solution... its adding 10-12 seconds. turning off ahci only saves a couple seconds but then the whole system is slower.

i have tried both platter and ssd drives, internal and external. Interestingly this only happens with ubuntu based distros but doesn't happen when booting from installer images for ANY distro.

The laptop is an ANCIENT lenovo L420 (blaze it) and I have tried Elementary os, Pop!, Ubuntu, and Zorin. All of them do it. I haven't tried debian, but I have tried Fedora, Arch which do not do this.

Other than changing AHCI settings, what do I do? Please hwlp!

You should check if there is any firmware update for the ancient Lenovo. That may be the solution.
Or you might have some luck with the grub parameter libata.force=noncq in order to disable AHCI ATA NCQ

sudo nano /etc/default/grub

Change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.force=noncq"

tap ctrl+o to overwrite, then enter to save current configuration. Tap ctrl+x to exit the editor.
Now, you must run

sudo update-grub

in order for the changes to take effect. Reboot and test...

1 Like

No fw updates. The same thing is also happening on an older Asus I have

I'll try the libata line.

Just got home. Wish me the lucks!

1 Like


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.