Slow Wifi Speed - Zorin OS Lite 16.3

Hello, I am new to Zorin OS, i just installed it a few days ago and one thing I have noticed is that my wifi speed is very slow compared to Windows.

Speed Test:

In WIndows, my download speed would normally be around 30-40mbps.
I have updated my software and kernel to the lastest.

Can someone please help.

What machine make / model are you using?

And - please post the output of sudo lshw -C network from terminal.

Looks like Ookla from the screenshot - have you tried other sources like or speedtest-cli (need to install first) in terminal?

Also, are you using 2.4Ghz wireless?

The PC I am using is a: Lenovo ThinkCentre M91p

This is the output of sudo lshw -C network

Also, I am getting similar results of speed in and speedtest-cli.

So, since it's USB - give this a shot..

In terminal, sudo apt install libusb-dev, reboot, and then give it another speed test. That package helps with USB's that aren't playing well. Not a cure-all but, might help. I've had to use that package to get other USB's working on my side many times; usually cheaper devices.. But, give that a try :+1:

And also since it's USB, what does lsusb output; and is that the right version for the adapter, r8188eu?

The command didn't seem to help that much

output of lsusb

In terminal, please run

nmcli dev wifi list

And check if your Rate for your network is listed for 130mb/s.

My network rate is listed for 195 mbits/s

Gotcha - and yes lsusb did have more info, appreciated; going off of your HW ID (0bda:8179), you may need to try this driver: GitHub - lwfinger/rtl8188eu: Repository for stand-alone RTL8188EU driver.

But, from other searches - looks like Ubuntu 12 was being used, like fully supported.. If libusb-dev didn't provide anything useful, you may need to try the linked driver, or another one. Which, seemed to be pretty vast - the one I linked (maybe..) was the newest but, also stopped support in 2019 looks like.

Is the adapter you're using have both Bluetooth and WiFi? I saw some posts about a combined adapter with the same name, 8188eu.

Hello, I am not sure how to install that driver, I am new to linux.
And to answer your question, No, my adapter is only for WiFi.

No worries - so, open the link in the post to the GitHub page, click the green code button at the top right of the title, select 'download .zip' at the bottom. After the download completes, open the file manager to Downloads, then extract the new file (right click, 'Extract Here') - once that's completed, open a terminal and navigate to the new folder:

cd Downloads/rtl8188eu-master

Then to make and install:

sudo make install
sudo modprobe -v 8188eu (may be different like rtl8188eu, or rt8188eu)

A successful modprobe will return nothing in terminal - just fyi..

May want to check ls /lib/firmware/rtlwifi/ to see if any .bins are already there before trying the downloaded firmware - you may hide them temporarily to test the downloaded driver; just rename the file with .filename.bin format. If the new driver doesn't work or isn't exhibiting desired results, you can remove the downloaded driver with sudo modprobe -r rt8188eu (or what the .bin is named in /lib/firmware/rtlwifi), un-hide the old drivers, rerun modprobe -v rt8188eu and that will load the last firmware version of that device. You can use terminal to rename the files like:

sudo cp /lib/firmware/rtlwifi/file.bin /lib/firmware/rtlwifi/.file.bin

to hide --

sudo cp /lib/firmware/rtlwifi/.file.bin /lib/firmware/rtlwifi/file.bin

to remove the hidden attribute.

Just remember the (.) on the front of any file will make it hidden, if not already known..

This is the output I am getting after running those commands:

Do this: remove all the downloaded zip and extracted folders, cd to your Downloads folder, then run git clone - cd into rtl8188eu, then try the make commands again.. Haven't had to do this much myself but, the first line after modprobe -v says only the 'git clone' method is supported; didn't see that bit! You won't have to extract this time using git clone either.

I am still getting the same errors

Are you copying / pasting the whole text from 'make' to 'modprobe' from my earlier post? Each line would be a separate command entered after finishing the previous one.


make - then sudo make install - modprobe may or may not be needed, from a guide I just found it doesn't appear to be needed..

But, since it is in fact working without having to install extra drivers - are you able to achieve any higher speeds by just swapping to a different USB port?

And the found article, has some steps:

Just follow where it starts from the 'make' section at number 6.

I have managed to install the driver using the article but my speeds haven't improved.

1 Like

What is your output for


If this is a notebook computer, have you disabled Power Management on networking?

1 Like

Power management is off

If you run

sudo nano /etc/modprobe.d/iwlwifi.conf

does it show 11n_disable=1 ?
If it does, then try setting the value to 8:

Restart network manager or reboot to test...

This is the output:

@Prem1 did you end up finding a solution?