Snap libva Intel driver failed

When attempting to launch Termius, the following occurs:

@MCRN:~$ /snap/termius-app/current/termius-app
libva error: /usr/lib/x86_64-linux-gnu/dri/ init failed
libva error: /usr/lib/x86_64-linux-gnu/dri/ init failed

Simmiler issue was reported in March 2022 for Ubuntu, which seems to have been resolved: Bug #1966571 “libva error: /usr/lib/x86_64-linux-gnu/dri/i965_dr...” : Bugs : mesa package : Ubuntu

Any assistance with resolving this would be awesome, I use Termius daily and am unable to use it at the moment due to this bug

Have you tried removing the double sandboxed Snap Version and installing a Debian packaged Termius application?

Yes, get the exact same error

Can you please run:

sudo apt-get update && sudo apt-get install --reinstall intel-media-va-driver:amd64

Reboot and test

I have actually already tried that, and unfortunately it made no difference

Can you paste the output of

sudo lshw -C video

Sure, no problem

@MCRN:~# lshw -C video
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 0c
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:600-5ff iomemory:400-3ff irq:142 memory:6000000000-6000ffffff memory:4000000000-400fffffff ioport:5000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

Well... its response was unhelpfully generic.

It looks like this is the package you need:

But that may conflict with the currently installed intel media driver.

What this means for you: You have the option of using Ubuntu 22.04 to get this solved instead of Zorin OS if that is what it takes. So even if our troubleshooting is unsuccessful, you are not left hanging.

Please review the bottom answer here:

This is an interesting bit of information.
Their issue was with Chrome, not Termius, but the principle should be the same.

Correct, the principle is the same, hopefully one if the dev guys can pick this up and try to fix this

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.