Software app crashing immedietly after launching

So after launching Software app it shows downloading catgalog, then apps show for less than a second on the main page/tab and the window disapears (some type of crash).

I tried launching from terminal to see if there were any error logs, just getting this:

~$ gnome-sof    tware
16:27:51:0302 Gs  enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refine-repos, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, appstream, snap, desktop-menu-path, flatpak, hardcoded-blacklist, modalias, packagekit-refine, rewrite-resource, packagekit-history, provenance, systemd-updates, generic-updates, provenance-license, icons, key-colors, key-colors-metadata
16:27:51:0302 Gs  disabled plugins: dpkg, dummy, repos
16:27:57:0689 Gs  automatically prevented from changing kind on system/snap/*/runtime/io.snapcraft.core20-DLqre5XGLbDqg9jPtiAhRRjDuPVa5X1q/latest/stable from runtime to unknown!
16:27:57:0931 Gs  automatically prevented from changing kind on system/snap/*/desktop/io.snapcraft.snapd-PMrrV4ml8uWuEUDBT8dSGnKUYbevVhc4/latest/stable from desktop to unknown!
Segmentation fault

So not super helpful. One thing to note is that if I run as sudo, i.e.

sudo gnome-software

Then the app stays open. I already tried the solution here: The app center and discord keeps crashing/doesnt lanuch zorin 16 - #9 by kj38

I've tried the above and also restarted several times.

The Snap Store side of Software Store has been troublesome.

I would recommend removing it if you are not using it.
First, check if you are using any snap packages:
ctrl+alt+t to open terminal; then run

snap list

If you are not using any snap packages, then:

sudo apt remove --purge snapd

sudo apt install --reinstall gnome-software && sudo reboot

Then test Software for proper functionality.

Thanks, there is one piece of software that is using snap. But I can remove it. When I have more time I will look into it.

...

Interestingly after waking my laptop up from sleep mode the Software store is working again. Haven't changed anything since the initial post so not sure why. Also the snap errors are gone when running from command line (but again the app is launching so maybe error are happening but just not being printed to console anymore).

Anyways, I will follow the steps as a precaution if snap is a known issue the the store.

1 Like

Removing the snap plugin fixes the issue, but it makes your store ugly because there are no suggestions.

Recommend using Synaptic Package Manager, it gives more detail of what the software is and is generally more useful than Gnome Software.