"Software" app not working properly. Keeps infinetly loading, items don't render

Hello,

Whenever I try to use the "Software" application, I face lots of problems such as the items not rendering in the application, search not working and showing an infinite loading screen, etc.

I'm not using a VPN, my internet is fast and good, everything works except for this application.

I feel that installing apps like on a smartphone is for a closed system and not suitable for a PC.

2 Likes

There are two likely causes for Gnome-Software failing to load:

  • The flatpak plugin failing to communicate with the server.
  • Something cached in Gnome-Software is creating a conflict.

End all processes with the software store

killall gnome-software

Remove the cache

rm -rf ~/.cache/gnome-software

Reinstall the packages:

sudo apt install --reinstall gnome-software gnome-software-plugin-flatpak

2 Likes

This has worked thankfully. Now I'm trying to install the "Windows app support" package but it's been stuck on 0% for quite some time now. Again, I face no internet connection issue anywhere, and everything is working perfectly, with and without the internet. I'm not sure about the cause of this situation. Could you help?

I clicked "cancel" which resulted in showing me a notification as in the following image

Let's try to get a verbose description of what is wrong.
Can you please open terminal and run

sudo apt install zorin-windows-app-support

and relay what errors are shown?

Just a point of interest...I thought the Windows App Support came with 16.2 or one of the quick patches after it?

No, it has been around quite a while. Zorin OS used to come with WIne pre-installed.
In Zorin OS 12, Wine no longer came pre-installed as the ZorinGroup worked on solving some issues with the compatibility layer.
Zorin 13 and Zorin 14 never existed - the Zoringroup named the next version 15 in order to account for two versions released in prior years that fell between the numbering system.
In Zorin 15, it was reintroduced as Zorin WIndows App Support as a Zorin Repository supported item that can be installed, but also does not come pre-installed.

Personally I agree with the choice to not include it as default.

1 Like

Ah...OK I see. I just never did notice it until I went to 16.2...oversite on my part. :slight_smile:

I know I tried to install the MS Spider with POL and it failed the True Type fonts. I have the MScore fonts installed but It specifies the FreeType set so I got to figure how to install those. I found .deb at pkgs but it balked at installation. I still need to fuddle with it again.

Off topic banter:
Have you tried

sudo apt install ttf-mscorefonts-installer

sudo fc-cache -vr

I reinstalled the software application and then installing worked. Thank you so much.

1 Like

Not the cache vr command. I will give that a try.

Apologies for the OT conversation. I did not realise the thread was marked Solved. :face_with_open_eyes_and_hand_over_mouth:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.